summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Richard2015-06-27 09:07:11 -0400
committerAlbert Richard2015-06-27 09:07:11 -0400
commit2c7e844eaefde557ddb1eb75d4160bb4524f620b (patch)
treee39fbbc6dceb1f0185b9d8a7d358b473674c896d
downloadaur-2c7e844eaefde557ddb1eb75d4160bb4524f620b.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8059920a512
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python2-gpsoauth
+ pkgdesc = client library for Google Play Services OAuth
+ pkgver = 0.0.3
+ pkgrel = 1
+ url = https://github.com/simon-weber/gpsoauth
+ arch = any
+ license = BSD
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-requests>=2.7
+ depends = python2-crypto>=2.6
+ depends = python2-pyasn1>=0.1.7
+ depends = python2-pyopenssl>=0.15
+ depends = python2-ndg-httpsclient>=0.4
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/g/gpsoauth/gpsoauth-0.0.3.tar.gz
+ md5sums = 96c8f81024c761ed94de1e2b7efd1cb1
+
+pkgname = python2-gpsoauth
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93f245a591ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: A. Richard <dubitae@gmail.com>
+pkgname=python2-gpsoauth
+_pipyname=gpsoauth
+pkgver=0.0.3
+pkgrel=1
+pkgdesc="client library for Google Play Services OAuth"
+arch=('any')
+url="https://github.com/simon-weber/gpsoauth"
+license=('BSD')
+groups=()
+depends=(
+ 'python2'
+ 'python2-requests>=2.7'
+ 'python2-crypto>=2.6'
+ 'python2-pyasn1>=0.1.7'
+ 'python2-pyopenssl>=0.15'
+ 'python2-ndg-httpsclient>=0.4'
+)
+makedepends=('python2-setuptools')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+changelog=
+source=("https://pypi.python.org/packages/source/g/$_pipyname/$_pipyname-$pkgver.tar.gz")
+noextract=()
+md5sums=('96c8f81024c761ed94de1e2b7efd1cb1')
+
+package() {
+ cd "$srcdir/$_pipyname-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}