summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Müllner2015-06-10 20:06:26 +0200
committerDaniel Müllner2015-06-10 20:06:26 +0200
commit1ed975426421cefc70a547eab3bf0500d35a63ec (patch)
treeabfafb66ec32549f576e943f2fe318d87126e8f3
downloadaur-1ed975426421cefc70a547eab3bf0500d35a63ec.tar.gz
Initial import, version 2.2.43
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD42
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..35b03f010bfd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = python2-graph-tool
+ pkgdesc = A Python module for manipulation and statistical analysis of graphs
+ pkgver = 2.2.43
+ pkgrel = 1
+ url = http://projects.skewed.de/graph-tool/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = sparsehash
+ makedepends = python2-cairo
+ depends = boost
+ depends = python2
+ depends = expat
+ depends = python2-scipy
+ depends = python2-numpy
+ depends = cgal
+ optdepends = graphviz: graph layout
+ optdepends = cairomm: graph drawing
+ optdepends = python2-cairo: graph drawing
+ optdepends = python2-matplotlib: graph drawing
+ options = !libtool
+ source = http://downloads.skewed.de/graph-tool/graph-tool-2.2.43.tar.bz2
+ sha256sums = c0ef941dc611fad5800c64417543e751f9edaeb511460ba06a43263c5b0efbd6
+
+pkgname = python2-graph-tool
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c045a812d411
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Daniel Müllner <daniel@danifold.net>
+
+# Remove the --enable-openmp flag below if you do not want parallelization.
+
+pkgname=python2-graph-tool
+pkgver=2.2.43
+pkgrel=1
+pkgdesc='A Python module for manipulation and statistical analysis of graphs'
+arch=('i686' 'x86_64')
+url='http://projects.skewed.de/graph-tool/'
+license=(GPL3)
+depends=(boost python2 expat python2-scipy python2-numpy cgal)
+makedepends=(sparsehash python2-cairo)
+optdepends=('graphviz: graph layout'
+'cairomm: graph drawing'
+'python2-cairo: graph drawing'
+'python2-matplotlib: graph drawing')
+options=(!libtool)
+source=("http://downloads.skewed.de/graph-tool/graph-tool-$pkgver.tar.bz2")
+sha256sums=('c0ef941dc611fad5800c64417543e751f9edaeb511460ba06a43263c5b0efbd6')
+
+prepare() {
+ cd "$srcdir/graph-tool-$pkgver"
+ ./configure --enable-openmp --prefix=/usr --docdir="/usr/share/doc/$pkgname" PYTHON=python2
+ # Remove information about the source directory, which is temporary.
+ sed -i 's|#define PACKAGE_SOURCE_DIR ".*"|/* removed since the source directory is temporary */|' config.h
+}
+
+build() {
+ cd "$srcdir/graph-tool-$pkgver"
+ make
+}
+
+check() {
+ cd "$srcdir/graph-tool-$pkgver"
+ make check
+}
+
+package() {
+ cd "$srcdir/graph-tool-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}