summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTiago de Paula Peixoto2016-09-22 11:37:56 +0200
committerTiago de Paula Peixoto2016-09-22 11:37:56 +0200
commitb036f447075e0bac1f671a6d45f8744446dca8cf (patch)
treece3d18d56f371068b10c1815596e412e54fcf60e
parent2851e23f75274353e202e70ff4f049449b96279d (diff)
downloadaur-b036f447075e0bac1f671a6d45f8744446dca8cf.tar.gz
Fix compilation problem with newer CGAL
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Fix-compilation-problem-with-newer-CGAL.patch76
-rw-r--r--PKGBUILD7
3 files changed, 83 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50a88121b8e8..290e43c8c0b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu Jul 21 22:18:31 UTC 2016
+# Thu Sep 22 09:37:31 UTC 2016
pkgbase = python2-graph-tool
pkgdesc = A Python module for manipulation and statistical analysis of graphs
pkgver = 2.18
@@ -21,7 +21,9 @@ pkgbase = python2-graph-tool
optdepends = python2-matplotlib: graph drawing
options = !libtool
source = http://downloads.skewed.de/graph-tool/graph-tool-2.18.tar.bz2
+ source = 0001-Fix-compilation-problem-with-newer-CGAL.patch
sha256sums = 3c4929fb7b6bae13a12115afdf8c07d6531aeeba548305376ba7b0ac710ec4d4
+ sha256sums = 6d325261f5e592c45c8eafb5c0b82d28e16fe4a11335d2c0c49f8e3439007f09
pkgname = python2-graph-tool
diff --git a/0001-Fix-compilation-problem-with-newer-CGAL.patch b/0001-Fix-compilation-problem-with-newer-CGAL.patch
new file mode 100644
index 000000000000..456e2f672aaa
--- /dev/null
+++ b/0001-Fix-compilation-problem-with-newer-CGAL.patch
@@ -0,0 +1,76 @@
+From 2a4aa1fbe40c2398e7cf008c360a3dcecad0c804 Mon Sep 17 00:00:00 2001
+From: Tiago de Paula Peixoto <tiago@skewed.de>
+Date: Wed, 21 Sep 2016 11:26:51 +0200
+Subject: [PATCH] Fix compilation problem with newer CGAL
+
+---
+ src/graph/generation/graph_triangulation.cc | 16 +++++++++-------
+ src/graph/generation/graph_triangulation.hh | 8 ++++----
+ 2 files changed, 13 insertions(+), 11 deletions(-)
+
+diff --git a/src/graph/generation/graph_triangulation.cc b/src/graph/generation/graph_triangulation.cc
+index 5642785..f63509a 100644
+--- a/src/graph/generation/graph_triangulation.cc
++++ b/src/graph/generation/graph_triangulation.cc
+@@ -15,10 +15,10 @@
+ // You should have received a copy of the GNU General Public License
+ // along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+-// As a special exception, you have permission to link this program
+-// with the CGAL library and distribute executables, as long as you
+-// follow the requirements of the GNU GPL in regard to all of the
+-// software in the executable aside from CGAL.
++// As a special exception, you have permission to link this program
++// with the CGAL library and distribute executables, as long as you
++// follow the requirements of the GNU GPL in regard to all of the
++// software in the executable aside from CGAL.
+
+ #include "graph.hh"
+ #include "graph_util.hh"
+@@ -52,11 +52,12 @@ bool operator==(const SimpleTriangulation::Vertex& a,
+
+ // periodic triangulation is only available in more recent versions of CGAL
+ #if (CGAL_VERSION_NR >= 1030500000)
+-#include <CGAL/Periodic_3_triangulation_traits_3.h>
++#include <CGAL/Periodic_3_Delaunay_triangulation_traits_3.h>
+ #include <CGAL/Periodic_3_Delaunay_triangulation_3.h>
+-typedef CGAL::Periodic_3_triangulation_traits_3<Kernel> GT;
++typedef CGAL::Periodic_3_Delaunay_triangulation_traits_3<Kernel> GT;
+ typedef CGAL::Periodic_3_Delaunay_triangulation_3<GT>
+ PeriodicDelaunayTriangulation;
++
+ namespace CGAL
+ {
+ bool operator==(const PeriodicDelaunayTriangulation::Vertex& a,
+@@ -85,7 +86,8 @@ void triangulation(GraphInterface& gi, boost::python::object points,
+
+ if (type == "simple")
+ {
+- get_triangulation<SimpleTriangulation, std::false_type>()(g, points_array, pos_map);
++ get_triangulation<SimpleTriangulation, std::false_type>()
++ (g, points_array, pos_map);
+ }
+ else if (type == "delaunay")
+ {
+diff --git a/src/graph/generation/graph_triangulation.hh b/src/graph/generation/graph_triangulation.hh
+index fffebe1..441bce5 100644
+--- a/src/graph/generation/graph_triangulation.hh
++++ b/src/graph/generation/graph_triangulation.hh
+@@ -15,10 +15,10 @@
+ // You should have received a copy of the GNU General Public License
+ // along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+-// As a special exception, you have permission to link this program
+-// with the CGAL library and distribute executables, as long as you
+-// follow the requirements of the GNU GPL in regard to all of the
+-// software in the executable aside from CGAL.
++// As a special exception, you have permission to link this program
++// with the CGAL library and distribute executables, as long as you
++// follow the requirements of the GNU GPL in regard to all of the
++// software in the executable aside from CGAL.
+
+ #ifndef GRAPH_TRIANGULATION_HH
+ #define GRAPH_TRIANGULATION_HH
+--
+2.10.0
+
diff --git a/PKGBUILD b/PKGBUILD
index a0f124ec5531..69e259b8cbbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,12 +14,13 @@ makedepends=(sparsehash)
optdepends=('graphviz: graph layout'
'python2-matplotlib: graph drawing')
options=(!libtool)
-source=("http://downloads.skewed.de/graph-tool/graph-tool-$pkgver.tar.bz2")
-sha256sums=('3c4929fb7b6bae13a12115afdf8c07d6531aeeba548305376ba7b0ac710ec4d4')
+source=("http://downloads.skewed.de/graph-tool/graph-tool-$pkgver.tar.bz2" "0001-Fix-compilation-problem-with-newer-CGAL.patch")
+sha256sums=('3c4929fb7b6bae13a12115afdf8c07d6531aeeba548305376ba7b0ac710ec4d4'
+ '6d325261f5e592c45c8eafb5c0b82d28e16fe4a11335d2c0c49f8e3439007f09')
prepare() {
cd "$srcdir/graph-tool-$pkgver"
- autoconf
+ patch -Np1 < ../0001-Fix-compilation-problem-with-newer-CGAL.patch
./configure --enable-openmp --prefix=/usr --docdir="/usr/share/doc/$pkgname" PYTHON=python2
}