summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHector Mtz-Seara2015-07-15 16:34:46 +0300
committerHector Mtz-Seara2015-07-15 16:34:46 +0300
commit0ebc07532ecfc172c1107d4f9a0b673320c0f794 (patch)
treea5bae174f3bb5a9d3440597183cf023aa91c21c5
downloadaur-0ebc07532ecfc172c1107d4f9a0b673320c0f794.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..04869cbafb56
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-griddataformats
+ pkgdesc = The gridDataFormats package provides classes to unify reading and writing n-dimensional datasets. One can read grid data from files, make them available as a Grid object, and allows one to write out the data again.
+ pkgver = 0.2.5
+ pkgrel = 1
+ url = https://github.com/orbeckst/GridDataFormats/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python2-numpy
+ source = https://github.com/orbeckst/GridDataFormats/archive/release-0.2.5.tar.gz
+ sha1sums = 6b545feb6acd7d5ba9a035360e17706e713d4416
+
+pkgname = python2-griddataformats
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca1e8e83cd7b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+#Contributor: Hector Mtz-Seara (hseara#at#gmail#com)
+pkgname=python2-griddataformats
+pkgver=0.2.5
+pkgrel=1
+pkgdesc="The gridDataFormats package provides classes to unify reading and writing n-dimensional datasets. One can read grid data from files, make them available as a Grid object, and allows one to write out the data again."
+url="https://github.com/orbeckst/GridDataFormats/"
+license="GPL"
+arch=('i686' 'x86_64')
+depends=('python2-numpy')
+
+
+source=(https://github.com/orbeckst/GridDataFormats/archive/release-$pkgver.tar.gz)
+sha1sums=('6b545feb6acd7d5ba9a035360e17706e713d4416')
+
+build() {
+ cd $srcdir/GridDataFormats-release-$pkgver
+ python2 setup.py build
+}
+
+package(){
+ cd $srcdir/GridDataFormats-release-$pkgver
+ python2 setup.py install --root=$pkgdir --optimize=1
+}