summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2019-06-25 00:37:57 -0400
committerJames An2019-06-25 00:37:57 -0400
commitb76d195c37c15d73d3b5930f49fb06fdab0b1289 (patch)
tree678532c872be8189c7a85305fcfaa23b3213b81e
parentf5f989bc5646b7870eaf46da916a2f9683c30b4d (diff)
downloadaur-b76d195c37c15d73d3b5930f49fb06fdab0b1289.tar.gz
Minor PKGBUILD cleanup and file permission correction.
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 279f399b66c8..b724506fa473 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,12 +22,14 @@ build() {
check() {
cd "$_pkgname-$pkgver"
-
+
python2 setup.py test
}
package() {
cd "$_pkgname-$pkgver"
-
+
python2 setup.py install --root="$pkgdir" --optimize=1
+ find $pkgdir -type f -exec chmod 0644 {} +
+ find $pkgdir -type d -exec chmod 0755 {} +
}