summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2015-06-13 17:59:23 +0200
committerMuflone2015-06-13 17:59:23 +0200
commit00023247225a25ffc3c61cbab08c2283193f76fe (patch)
tree404b6b574b4d235e4a69be9b137b8178f73c00f1
downloadaur-python2-gudev-git.tar.gz
Initial import
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD55
-rw-r--r--configure.patch17
-rw-r--r--makefile.patch11
4 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc60674c2638
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = python2-gudev-git
+ pkgdesc = Python (PyGObject) bindings to the GUDev library
+ pkgver = 147.2.1.g780b007
+ pkgrel = 2
+ url = http://github.com/nzjrs/python-gudev
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ makedepends = git
+ depends = systemd
+ depends = python2
+ provides = python2-gudev
+ provides = python-gudev
+ conflicts = python2-gudev
+ conflicts = python-gudev
+ replaces = conduit-svn
+ options = !libtool
+ source = git://github.com/nzjrs/python-gudev.git
+ source = configure.patch
+ source = makefile.patch
+ md5sums = SKIP
+ md5sums = 0ab9c9f78c88023b86703d503630da10
+ md5sums = 5e610a3a114df81b8598d91e2ed46f30
+ sha1sums = SKIP
+ sha1sums = f12d3a0849205d55b43106d3bc088a89ce21d290
+ sha1sums = 517dd3bbe346b1627745d1dc5affc04786b16ec1
+ sha256sums = SKIP
+ sha256sums = 5db0bd5945e6564cb8c602a5f3b63168b85e483eccf286ed294e6df571c3f62b
+ sha256sums = e3b6be0db49b4f90d2e89fbb4dff0f194d8514a2d1577ee81a76c5e4dc2e50bc
+
+pkgname = python2-gudev-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bd5e6d9525f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Muflone <webreg@vbsimple.net>
+# Contributor: SergHeart
+# Contributor: Matthew Bauer <mjbauer95@gmail.com>
+
+pkgname=python2-gudev-git
+_gitname=python-gudev
+pkgver=147.2.1.g780b007
+pkgrel=2
+pkgdesc="Python (PyGObject) bindings to the GUDev library"
+arch=('i686' 'x86_64')
+url="http://github.com/nzjrs/python-gudev"
+license=('LGPL3')
+depends=('systemd' 'python2')
+makedepends=('git')
+provides=("python2-gudev" "python-gudev")
+conflicts=("python2-gudev" "python-gudev")
+replaces=('conduit-svn')
+source=("git://github.com/nzjrs/python-gudev.git"
+ "configure.patch"
+ "makefile.patch")
+md5sums=('SKIP'
+ '0ab9c9f78c88023b86703d503630da10'
+ '5e610a3a114df81b8598d91e2ed46f30')
+sha1sums=('SKIP'
+ 'f12d3a0849205d55b43106d3bc088a89ce21d290'
+ '517dd3bbe346b1627745d1dc5affc04786b16ec1')
+sha256sums=('SKIP'
+ '5db0bd5945e6564cb8c602a5f3b63168b85e483eccf286ed294e6df571c3f62b'
+ 'e3b6be0db49b4f90d2e89fbb4dff0f194d8514a2d1577ee81a76c5e4dc2e50bc')
+options=('!libtool')
+
+pkgver() {
+ cd "${_gitname}"
+ git describe --always | sed 's|-|.|g'
+}
+
+prepare() {
+ cd "${_gitname}"
+ patch -p1 -i ../configure.patch
+ patch -p1 -i ../makefile.patch
+}
+
+build() {
+ cd "${_gitname}"
+ ./autogen.sh
+ ./configure --prefix=/usr PYTHON=python2
+ sed -i '/#include <pygobject\.h>/ i#include <python2.7/Python.h>' "gudevmodule.c"
+ make
+}
+
+package() {
+ cd "${_gitname}"
+ make DESTDIR="${pkgdir}" install
+}
+
diff --git a/configure.patch b/configure.patch
new file mode 100644
index 000000000000..9622bf2e07df
--- /dev/null
+++ b/configure.patch
@@ -0,0 +1,17 @@
+--- python-gudev-build/configure.ac 2013-03-05 20:45:33.476890335 +0200
++++ python-gudev-build/configure.ac 2013-03-05 20:41:39.784145843 +0200
+@@ -2,13 +2,12 @@
+ AC_INIT(python-gudev, 147.3)
+ AC_CONFIG_SRCDIR(gudev.defs)
+ AC_CONFIG_MACRO_DIR([m4])
+-AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
++AM_INIT_AUTOMAKE
+
+ AM_MAINTAINER_MODE
+ AC_PROG_MAKE_SET
+
+ AC_PROG_CC
+-AM_PROG_CC_STDC
+ AC_HEADER_STDC
+
+ AM_PROG_LIBTOOL
diff --git a/makefile.patch b/makefile.patch
new file mode 100644
index 000000000000..60afa36e1142
--- /dev/null
+++ b/makefile.patch
@@ -0,0 +1,11 @@
+--- python-gudev-build/Makefile.am 2013-03-05 20:45:33.476890335 +0200
++++ python-gudev-build/Makefile.am 2013-03-05 20:38:29.431926745 +0200
+@@ -3,7 +3,7 @@
+
+ ACLOCAL_AMFLAGS = -I m4
+
+-INCLUDES = \
++AM_CPPFLAGS = \
+ $(GUDEV_CFLAGS) \
+ $(GOBJECT_CFLAGS) \
+ $(PYGOBJECT_CFLAGS) \