summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrzej Giniewicz2015-07-07 21:35:19 +0200
committerAndrzej Giniewicz2015-07-07 21:35:19 +0200
commit86d34bc31029f419c0a3046ba93fa5c776f83e94 (patch)
treef3d5b0ab8ac2814d664fa8e3c462c545ab60b798
downloadaur-86d34bc31029f419c0a3046ba93fa5c776f83e94.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD32
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c71ae8cba04
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python2-guiqwt
+ pkgdesc = Python library providing efficient 2D data-plotting features
+ pkgver = 2.3.1
+ pkgrel = 1
+ url = http://code.google.com/p/guiqwt/
+ arch = i686
+ arch = x86_64
+ license = custom:CeCIL
+ makedepends = python2-distribute
+ makedepends = unzip
+ makedepends = cython2
+ depends = python2-guidata
+ depends = pyqwt
+ depends = python2-scipy
+ depends = python-imaging
+ optdepends = python2-pydicom: for DICOM files I/O features
+ optdepends = spyder: for Sift embedded Python console
+ options = !emptydirs
+ source = http://guiqwt.googlecode.com/files/guiqwt-2.3.1.zip
+ md5sums = 4dbbfa7ca62f5d9222e7c84f8a8995c2
+
+pkgname = python2-guiqwt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..271ea4c42439
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
+pkgname=python2-guiqwt
+pkgver=2.3.1
+pkgrel=1
+pkgdesc="Python library providing efficient 2D data-plotting features"
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/guiqwt/"
+license=('custom:CeCIL')
+depends=('python2-guidata' 'pyqwt' 'python2-scipy' 'python-imaging')
+optdepends=('python2-pydicom: for DICOM files I/O features'
+ 'spyder: for Sift embedded Python console')
+makedepends=('python2-distribute' 'unzip' 'cython2')
+options=(!emptydirs)
+
+source=(http://guiqwt.googlecode.com/files/guiqwt-$pkgver.zip)
+md5sums=('4dbbfa7ca62f5d9222e7c84f8a8995c2')
+
+build() {
+ cd "$srcdir"/guiqwt-$pkgver
+
+ unset LDFLAGS
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir"/guiqwt-$pkgver
+
+ python2 setup.py install --root="$pkgdir"/ --optimize=1
+
+ install -Dm644 Licence_CeCILL_V2-en.txt "$pkgdir/usr/share/licenses/python2-guiqwt/LICENSE"
+}
+