summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabien Devaux2015-07-15 10:18:01 +0200
committerFabien Devaux2015-07-15 10:18:01 +0200
commitde7e066607c553b6e4a592cf0407da9e2cd5c463 (patch)
tree193f8e4f1a04df1fd5ba7592745f906cec103361
downloadaur-python2-howdoi.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aa1f431817d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-howdoi
+ pkgdesc = A code search tool
+ pkgver = 1.1.7
+ pkgrel = 3
+ url = https://github.com/gleitz/howdoi
+ arch = any
+ license = MIT
+ makedepends = python2-distribute
+ depends = python2
+ depends = python2-pyquery
+ depends = python2-requests-cache
+ depends = python2-pygments
+ depends = python2-requests
+ source = http://pypi.python.org/packages/source/h/howdoi/howdoi-1.1.7.tar.gz
+ md5sums = 0b77b526f365b844ea9cbea1eb65696a
+
+pkgname = python2-howdoi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea6379113923
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Fabien Devaux <fdev31 at gmail dot com>
+
+_pkg="howdoi"
+
+pkgname=python2-$_pkg
+pkgver=1.1.7
+pkgrel=3
+pkgdesc="A code search tool"
+arch=(any)
+url=("https://github.com/gleitz/howdoi")
+license=('MIT')
+depends=('python2' 'python2-pyquery' 'python2-requests-cache' 'python2-pygments' 'python2-requests')
+makedepends=('python2-distribute')
+source=("http://pypi.python.org/packages/source/h/${_pkg}/${_pkg}-${pkgver}.tar.gz")
+md5sums=('0b77b526f365b844ea9cbea1eb65696a')
+
+package() {
+ cd "$srcdir/$_pkg-$pkgver"
+ python2 setup.py build || return 1
+ python2 setup.py install --root=$pkgdir --optimize=1 || return 1
+}
+