summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVinicius Correa2018-03-21 10:30:13 -0300
committerVinicius Correa2018-03-21 10:30:13 -0300
commitcb16dd2c7e3c555726f7e0584ca7cec79032d8b0 (patch)
treed1a416443518a63c7a7ad13825d5a15c1bb52270
downloadaur-cb16dd2c7e3c555726f7e0584ca7cec79032d8b0.tar.gz
first version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af44e71afcb0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-htsql
+ pkgdesc = A comprehensive navigational query language for relational databases.
+ pkgver = 2.3.3
+ pkgrel = 1
+ url = http://htsql.org
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python2
+ depends = python2-pyaml
+ source = http://dist.htsql.org/source/HTSQL-2.3.3.tar.gz
+ md5sums = 34fabf3f4dbc578abba27540491185de
+
+pkgname = python2-htsql
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..271f2fc00526
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Vinicius Correa <vinicius dot correa at zoho dot com>
+_pkgname=HTSQL
+pkgname=python2-htsql
+pkgver=2.3.3
+pkgrel=1
+pkgdesc="A comprehensive navigational query language for relational databases."
+arch=('any')
+url="http://htsql.org"
+license=('GPL')
+depends=('python2' 'python2-pyaml')
+makedepends=('git')
+optdepends=()
+conflicts=()
+source=("http://dist.htsql.org/source/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('34fabf3f4dbc578abba27540491185de')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}