summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichele Mocciola2017-09-04 20:13:04 +0200
committerMichele Mocciola2017-09-04 20:13:04 +0200
commitc4ff909e1c953889fede29c709ce6feb70729804 (patch)
tree17e38eeec55e0cbc3d1b1dfc4b79ee1914011a00
parente04633f2aa10a7dd2a4fc8f1cd1db545d2834800 (diff)
downloadaur-python2-ifcopenshell-git.tar.gz
Updated to 0.5.0.preview2.r128.gc7c5e69
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47b3614fef18..ddb023a81e61 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue May 3 17:12:41 UTC 2016
+# Mon Sep 4 18:12:43 UTC 2017
pkgbase = python2-ifcopenshell-git
pkgdesc = Open source IFC library and geometry engine. Provides only wrapper for python2. GIT version.
- pkgver = 0.r550.gfefa8a0
+ pkgver = 0.5.0.preview2.r128.gc7c5e69
pkgrel = 1
url = http://ifcopenshell.org/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 84704af5c57e..3e53b5632685 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: mickele <mimocciola[at]yahoo[dot]com>
pkgname=python2-ifcopenshell-git
-pkgver=0.r550.gfefa8a0
+pkgver=0.5.0.preview2.r128.gc7c5e69
pkgrel=1
pkgdesc="Open source IFC library and geometry engine. Provides only wrapper for python2. GIT version."
url="http://ifcopenshell.org/"
@@ -39,6 +39,8 @@ prepare(){
sed -e "s|FIND_PACKAGE(Boost REQUIRED COMPONENTS system program_options regex thread date_time)|FIND_PACKAGE(Boost REQUIRED COMPONENTS system program_options regex thread date_time)\nADD_DEFINITIONS(-DBOOST_OPTIONAL_USE_OLD_DEFINITION_OF_NONE)|" -i cmake/CMakeLists.txt
sed -e "s|boost::shared_ptr<Representation::Triangulation<P>>|boost::shared_ptr<Representation::Triangulation<P> >|" -i src/ifcgeom/IfcGeomElement.h
+
+ sed -e "s|#include <iomanip>|#include <iomanip>\n#include <unicode/unistr.h>|" -i src/ifcparse/IfcCharacterDecoder.cpp
}
build() {
@@ -47,15 +49,18 @@ build() {
mkdir -p build
cd "${srcdir}/IfcOpenShell/build"
local _pythonver=$(python2 --version 2>&1)
- cmake ../cmake \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_CXX_STANDARD=11 \
-DOCC_INCLUDE_DIR=/opt/opencascade/inc \
-DOCC_LIBRARY_DIR=/opt/opencascade/lib \
-DOPENCOLLADA_INCLUDE_DIR=/usr/include/opencollada \
-DOPENCOLLADA_LIBRARY_DIR=/usr/lib/opencollada \
+ -DICU_INCLUDE_DIR=/usr/include/unicode \
+ -DICU_LIBRARY_DIR=/usr/lib \
-DPYTHON_INCLUDE_DIR:PATH=/usr/include/python${_pythonver:7:3} \
- -DPYTHON_LIBRARY:FILEPATH=/usr/lib64/libpython${_pythonver:7:3}.so
+ -DPYTHON_LIBRARY:FILEPATH=/usr/lib64/libpython${_pythonver:7:3}.so \
+ -DSWIG_EXECUTABLE=/usr/bin/swig \
+ ../cmake
make
}