summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2015-12-19 15:11:58 +0800
committerYen Chi Hsuan2015-12-19 15:11:58 +0800
commit405a7b1ad767a7155b07850ad557f7d1e6c1bdc0 (patch)
treeaf0b6580bb527d7b3be3070d9ae91203d106bca9
parentcafc228cb016f739907c7738ba59d5a9bd8bee8f (diff)
downloadaur-405a7b1ad767a7155b07850ad557f7d1e6c1bdc0.tar.gz
patch not necessary anymore
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD36
-rw-r--r--patch_freetype_includes.patch8
3 files changed, 16 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9a08414752b..0c6077444f2b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sat Dec 19 07:11:35 UTC 2015
pkgbase = python2-imaging
pkgdesc = PIL. Provides image processing capabilities for python
pkgver = 1.1.7
- pkgrel = 10
+ pkgrel = 11
url = http://www.pythonware.com/products/pil/index.htm
arch = i686
arch = x86_64
@@ -11,7 +13,6 @@ pkgbase = python2-imaging
license = custom:"pil"
makedepends = tk
makedepends = sane
- makedepends = patch
depends = python2
depends = libjpeg
depends = freetype2
@@ -19,16 +20,11 @@ pkgbase = python2-imaging
optdepends = tk: for the ImageTK module
optdepends = sane: for the ImageSane module
provides = pil=1.1.7
- provides = python-imaging=1.1.7
provides = python2-pillow=1.0
conflicts = pil
- conflicts = python-imaging
replaces = pil
- replaces = python-imaging
source = http://effbot.org/downloads/Imaging-1.1.7.tar.gz
- source = patch_freetype_includes.patch
md5sums = fc14a54e1ce02a0225be8854bfba478e
- md5sums = d0fdf5b560fb010dde8a9c40f1f84e9c
pkgname = python2-imaging
diff --git a/PKGBUILD b/PKGBUILD
index 84b94b762af7..c6647fa2e860 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer : jyantis <yantis@yantis.net>
+# Maintainer : Yen Chi Hsuan <yan12125@gmail.com>
+# Contributor: jyantis <yantis@yantis.net>
# Contributor: Rob McCathie <archaur at rmcc dot com dot au>
# Contributor: Yanus Poluektovich <ypoluektovich@gmail.com>
# Contributor: Kyle Keen <keenerd@gmail.com>
@@ -8,31 +9,20 @@
pkgname=python2-imaging
pkgver=1.1.7
-pkgrel=10
+pkgrel=11
pkgdesc="PIL. Provides image processing capabilities for python"
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'armv6l')
url="http://www.pythonware.com/products/pil/index.htm"
license=('custom:"pil"')
-depends=('python2' 'libjpeg' 'freetype2' 'lcms')
-makedepends=('tk' 'sane' 'patch')
+depends=('python2' 'libjpeg' 'freetype2' 'lcms')
+makedepends=('tk' 'sane')
optdepends=('tk: for the ImageTK module'
'sane: for the ImageSane module')
-provides=("pil=${pkgver}" "python-imaging=${pkgver}" 'python2-pillow=1.0')
-conflicts=('pil' 'python-imaging')
-replaces=('pil' 'python-imaging')
-source=(
- http://effbot.org/downloads/Imaging-${pkgver}.tar.gz
- patch_freetype_includes.patch
- )
-md5sums=('fc14a54e1ce02a0225be8854bfba478e'
- 'd0fdf5b560fb010dde8a9c40f1f84e9c')
-
-prepare() {
- pwd
- # Package "freetype2" has its includes in a directory with the same name,
- # but these sources want it in "freetype". This patch fixes it.
- patch "Imaging-${pkgver}/_imagingft.c" patch_freetype_includes.patch
-}
+provides=("pil=${pkgver}" 'python2-pillow=1.0')
+conflicts=('pil')
+replaces=('pil')
+source=(http://effbot.org/downloads/Imaging-${pkgver}.tar.gz)
+md5sums=('fc14a54e1ce02a0225be8854bfba478e')
build() {
cd "${srcdir}/Imaging-${pkgver}"
@@ -48,13 +38,13 @@ build() {
package() {
cd "${srcdir}/Imaging-${pkgver}"
python2 setup.py install --root="${pkgdir}" --optimize=1
-
+
pushd Sane
python2 setup.py install --root="${pkgdir}" --optimize=1
popd
-
+
install -dm755 "${pkgdir}/usr/include/python2.7/"
- install -m644 -t "${pkgdir}/usr/include/python2.7/" libImaging/*.h
+ install -m644 -t "${pkgdir}/usr/include/python2.7/" libImaging/*.h
# do not have files ending in .py in /usr/bin
for f in pildriver pilprint pilconvert pilfile pilfont; do
diff --git a/patch_freetype_includes.patch b/patch_freetype_includes.patch
deleted file mode 100644
index d2c6544f980f..000000000000
--- a/patch_freetype_includes.patch
+++ /dev/null
@@ -1,8 +0,0 @@
-35c35
-< #include <freetype/freetype.h>
----
-> #include <freetype2/freetype.h>
-73c73
-< #include <freetype/fterrors.h>
----
-> #include <freetype2/fterrors.h>