summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoe Bashe2021-05-15 22:12:29 -0700
committerJoe Bashe2021-05-15 22:12:29 -0700
commitcb696246874384d300e17045b7ddf5b4802a2e8c (patch)
tree9d69ea4c5e5e5a34a578e454c07630064153f42c
downloadaur-cb696246874384d300e17045b7ddf5b4802a2e8c.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..347739599338
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-incremental
+ pkgdesc = A small library that versions your Python projects.
+ pkgver = 21.3.0
+ pkgrel = 1
+ url = https://github.com/twisted/incremental
+ arch = any
+ license = GPL2
+ makedepends = python2-setuptools
+ depends = python2
+ source = https://github.com/twisted/incremental/archive/refs/tags/incremental-21.3.0.tar.gz
+ sha256sums = 57b6a0785f265ffe59a454276efac1062943bb5b7bff7b5505bf054a563c22c4
+
+pkgname = python2-incremental
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2afdcc18e96d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Joe Bashe <joe@bashe.joe>
+
+_name=incremental
+pkgname=python2-incremental
+pkgver=21.3.0
+pkgrel=1
+pkgdesc='A small library that versions your Python projects.'
+arch=('any')
+url='https://github.com/twisted/incremental'
+license=('GPL2')
+depends=('python2')
+makedepends=('python2-setuptools')
+source=("https://github.com/twisted/incremental/archive/refs/tags/incremental-$pkgver.tar.gz")
+sha256sums=('57b6a0785f265ffe59a454276efac1062943bb5b7bff7b5505bf054a563c22c4')
+
+build() {
+ cd "${_name}-${_name}-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${_name}-${_name}-${pkgver}"
+ python2 setup.py install --skip-build \
+ --optimize=1 \
+ --prefix=/usr \
+ --root="${pkgdir}"
+ install -vDm 644 {NEWS.rst,README.rst} \
+ -t "${pkgdir}/usr/share/doc/${pkgname}"
+}