summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Eitel2018-03-25 21:25:39 +0200
committerFlorian Eitel2018-03-25 21:31:31 +0200
commit70ef52e813ae8d4aed5fc754f5f8046813dc2aec (patch)
tree99045a962b13c1866fc0427f16fd4e0eebb43c65
parent2b36f8a1f07ce5233fe34453b54fbea07f47822b (diff)
downloadaur-70ef52e813ae8d4aed5fc754f5f8046813dc2aec.tar.gz
Update to version 5.0.0
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--LICENSE20
-rw-r--r--PKGBUILD29
4 files changed, 54 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27a5cb207bc0..4f18335cb618 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,22 @@
-# Generated by mksrcinfo v8
-# Wed Apr 13 08:45:01 UTC 2016
pkgbase = python2-influxdb
pkgdesc = Python client for InfluxDB
- pkgver = 2.12.0
+ pkgver = 5.0.0
pkgrel = 1
- url = https://github.com/influxdb/influxdb-python/
+ url = https://github.com/influxdb/influxdb-python
arch = any
license = MIT
- depends = python
+ depends = python2
+ depends = python2-dateutil
+ depends = python2-six
+ depends = python2-pytz
depends = python2-requests
optdepends = influxdb
+ optdepends = python2-pandas
options = !emptydirs
- source = https://github.com/influxdb/influxdb-python/archive/v2.12.0.tar.gz
- md5sums = 902947833fcad6fc0a9062fb4f2e1ff6
+ source = https://github.com/influxdb/influxdb-python/archive/v5.0.0.tar.gz
+ source = LICENSE
+ sha256sums = 7ff7427fb90dcdedc44b68def0d9a04b800d0ddf842fadd51d03034708b8dce0
+ sha256sums = 70146f78d168b33ac5903490a918469e22a801a8d3a81103f3d8706dc0024c9a
pkgname = python2-influxdb
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..17ac5abc4ae3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.tar.xz
+*.tar.gz
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..38ee24919e1f
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,20 @@
+The MIT License (MIT)
+
+Copyright (c) 2013 InfluxDB
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of
+this software and associated documentation files (the "Software"), to deal in
+the Software without restriction, including without limitation the rights to
+use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software is furnished to do so,
+subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS
+FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR
+COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 2743bd834c65..a828a76b4fbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,29 @@
# Maintainer: Daichi Shinozaki <dsdseg@gmail.com>
pkgname=python2-influxdb
-pkgver=2.12.0
+pkgver=5.0.0
pkgrel=1
pkgdesc="Python client for InfluxDB"
-arch=('any')
-url="https://github.com/influxdb/influxdb-python/"
-license=('MIT')
-depends=('python' 'python2-requests')
-optdepends=('influxdb')
+arch=(any)
+url=https://github.com/influxdb/influxdb-python
+license=(MIT)
+depends=(python2 python2-dateutil python2-six python2-pytz python2-requests)
+optdepends=(influxdb python2-pandas)
options=(!emptydirs)
source=("https://github.com/influxdb/influxdb-python/archive/v$pkgver.tar.gz")
-md5sums=('902947833fcad6fc0a9062fb4f2e1ff6')
+sha256sums=('7ff7427fb90dcdedc44b68def0d9a04b800d0ddf842fadd51d03034708b8dce0')
+source+=(LICENSE)
+sha256sums+=(70146f78d168b33ac5903490a918469e22a801a8d3a81103f3d8706dc0024c9a)
-package() {
+build() {
cd "$srcdir/influxdb-python-$pkgver"
- python2 setup.py install --root="$pkgdir/" --optimize=1
+ python2 setup.py build
}
-# vim:set ts=2 sw=2 et:
+package() {
+ cd "$srcdir/influxdb-python-$pkgver"
+ python2 setup.py install --skip-build --root="$pkgdir/" --optimize=1
+
+ if [[ -f LICENSE ]]; then
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ fi
+}