summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Eitel2018-03-25 21:37:26 +0200
committerFlorian Eitel2018-03-25 21:37:26 +0200
commit7ee3241d2bfe94be501baa0f22982e059dbc6ef0 (patch)
tree8fb9d7ec6e44e473404a46999e18582d677cd6d8
parentcb58d6fb47d8850a54547de855a38f67a5d9a07f (diff)
downloadaur-7ee3241d2bfe94be501baa0f22982e059dbc6ef0.tar.gz
Use LICENSE from source package
-rw-r--r--.SRCINFO2
-rw-r--r--LICENSE20
-rw-r--r--PKGBUILD6
3 files changed, 1 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f18335cb618..3f2bd8eb850d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,9 +14,7 @@ pkgbase = python2-influxdb
optdepends = python2-pandas
options = !emptydirs
source = https://github.com/influxdb/influxdb-python/archive/v5.0.0.tar.gz
- source = LICENSE
sha256sums = 7ff7427fb90dcdedc44b68def0d9a04b800d0ddf842fadd51d03034708b8dce0
- sha256sums = 70146f78d168b33ac5903490a918469e22a801a8d3a81103f3d8706dc0024c9a
pkgname = python2-influxdb
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 38ee24919e1f..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,20 +0,0 @@
-The MIT License (MIT)
-
-Copyright (c) 2013 InfluxDB
-
-Permission is hereby granted, free of charge, to any person obtaining a copy of
-this software and associated documentation files (the "Software"), to deal in
-the Software without restriction, including without limitation the rights to
-use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of
-the Software, and to permit persons to whom the Software is furnished to do so,
-subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in all
-copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS
-FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR
-COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
-IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
-CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 686187b1dbc7..f31b93213a2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,6 @@ optdepends=(influxdb python2-pandas)
options=(!emptydirs)
source=("https://github.com/influxdb/influxdb-python/archive/v$pkgver.tar.gz")
sha256sums=('7ff7427fb90dcdedc44b68def0d9a04b800d0ddf842fadd51d03034708b8dce0')
-source+=(LICENSE)
-sha256sums+=(70146f78d168b33ac5903490a918469e22a801a8d3a81103f3d8706dc0024c9a)
build() {
cd "$srcdir/influxdb-python-$pkgver"
@@ -30,7 +28,5 @@ package() {
cd "$srcdir/influxdb-python-$pkgver"
python2 setup.py install --skip-build --root="$pkgdir/" --optimize=1
- if [[ -f LICENSE ]]; then
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- fi
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}