summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Gerhaeuser2016-02-07 20:30:40 +0100
committerMichael Gerhaeuser2016-02-07 20:30:40 +0100
commitbb913454504f73ce69cf1af94605eba6f5716af2 (patch)
tree1c0aaf56ccfb2cd6d2fbe5c5cc7fb6de14d3005e
downloadaur-bb913454504f73ce69cf1af94605eba6f5716af2.tar.gz
Initial commit of python2-inifile 0.3
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..91044e73a623
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-inifile
+ pkgdesc = Ini file library for Python.
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://github.com/mitsuhiko/python-inifile
+ arch = any
+ license = BSD
+ makedepends = python2-setuptools
+ depends = python2
+ options = !emptydirs
+ source = https://github.com/mitsuhiko/python-inifile/archive/0.3.tar.gz
+ md5sums = de2ef0f997c880e9d30362310776b652
+
+pkgname = python2-inifile
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..79b42396cea8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Michael Gerhaeuser <michael.gerhaeuser@gmail.com>
+pkgname=python2-inifile
+_pkgname=python-inifile
+pkgver=0.3
+pkgrel=1
+pkgdesc="Ini file library for Python."
+arch=(any)
+url="https://github.com/mitsuhiko/python-inifile"
+license=('BSD')
+depends=(python2)
+makedepends=(python2-setuptools)
+options=(!emptydirs)
+source=("https://github.com/mitsuhiko/$_pkgname/archive/$pkgver.tar.gz")
+md5sums=("de2ef0f997c880e9d30362310776b652")
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}