summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-07 13:49:47 +0100
committerBartłomiej Piotrowski2018-01-07 13:49:47 +0100
commit737065ae617df22b59d0f9423970d086be15722c (patch)
tree1b83f2ced050e2b19cb6aa36c01e757cb05c0537
downloadaur-737065ae617df22b59d0f9423970d086be15722c.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cea4da4730da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python2-iniparse
+ pkgdesc = Better INI parser library for Python
+ pkgver = 0.4
+ pkgrel = 4
+ url = https://code.google.com/archive/p/iniparse/
+ arch = any
+ license = MIT
+ depends = python2
+ source = https://pypi.python.org/packages/source/i/iniparse/iniparse-0.4.tar.gz
+ sha1sums = 2b2af8a19f3e5c212c27d7c524cd748fa0b38650
+
+pkgname = python2-iniparse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b7ca561fd5d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 276082 2017-12-26 02:22:10Z eschwartz $
+# Maintainer:
+# Contributor: nblock <nblock [/at\] archlinux DOT us>
+# Contributor: Dino Krtanjek <krtanjekdino@gmail.com>
+
+pkgname=python2-iniparse
+pkgver=0.4
+pkgrel=4
+pkgdesc='Better INI parser library for Python'
+arch=('any')
+license=('MIT')
+url='https://code.google.com/archive/p/iniparse/'
+depends=('python2')
+source=("https://pypi.python.org/packages/source/i/iniparse/iniparse-${pkgver}.tar.gz")
+sha1sums=('2b2af8a19f3e5c212c27d7c524cd748fa0b38650')
+
+build() {
+ cd "${srcdir}/iniparse-${pkgver}"
+ python2 ./setup.py build
+}
+
+package() {
+ cd "${srcdir}/iniparse-${pkgver}"
+ python2 ./setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}