summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2015-06-15 15:51:06 -0400
committerSolomon Choina2015-06-15 15:51:06 -0400
commit28fe717f449e4fd602a4a024cc39b39a1f0553d8 (patch)
treea954085b3e3b68bf173e41c661b97ae618c29e24
downloadaur-28fe717f449e4fd602a4a024cc39b39a1f0553d8.tar.gz
initial import and a movement to the arch standards of python2
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7b86822d869
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by makepkg 4.2.0
+# Wed Jan 7 04:22:31 UTC 2015
+pkgbase = inotifyx
+ pkgdesc = A simple Python binding to the Linux inotify file system event monitoring API
+ pkgver = 0.2.0
+ pkgrel = 2
+ url = http://www.alittletooquiet.net/software/inotifyx/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = python2
+ options = !emptydirs
+ source = http://launchpad.net/inotifyx/dev/v0.2.0/+download/inotifyx-0.2.0.tar.gz
+ sha1sums = e29996f6882227e390464de2185eb25fc4e0c951
+
+pkgname = inotifyx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..825b55e43239
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# INotifyX: Installer: Arch
+# Maintainer: Tom Vincent <http://tlvince.com/contact>
+# Contributor: Xavion <Xavion (dot) 0 (at) Gmail (dot) com>
+
+pkgname=python2-inotifyx
+_pkgname=inotifyx
+pkgver=0.2.0
+pkgrel=5
+pkgdesc="A simple Python binding to the Linux inotify file system event monitoring API"
+arch=("i686" "x86_64")
+url="http://www.alittletooquiet.net/software/inotifyx/"
+license=("MIT")
+depends=("python2")
+options=(!emptydirs)
+provides=(inotifyx)
+conflicts=(inotifyx)
+source=(http://launchpad.net/${_pkgname}/dev/v${pkgver}/+download/${_pkgname}-${pkgver}.tar.gz)
+sha1sums=('e29996f6882227e390464de2185eb25fc4e0c951')
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+
+ # Install
+ python2 setup.py install --prefix=/usr --root=${pkgdir} || return 1
+}