summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2018-09-08 20:10:09 -0400
committerGI_Jack2018-09-08 20:10:09 -0400
commit70ec1cea8ed57a51320e0666ec3d34e95491fe43 (patch)
treef52a24f6769cff3733f0f78562d372e68a15858e
downloadaur-70ec1cea8ed57a51320e0666ec3d34e95491fe43.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31107a0e209f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Sep 9 00:07:44 UTC 2018
+pkgbase = python2-ipwhois
+ pkgdesc = Retrieve and parse whois data for IPv4 and IPv6 addresses
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/secynic/ipwhois
+ arch = any
+ license = MIT
+ depends = python2
+ depends = python2-dnspython
+ source = https://github.com/secynic/ipwhois/archive/v1.0.0.zip
+ sha512sums = 678ca8b3e9cbc41b364536f6b0e84053a0385a9238c22afcb6e860e4097e4c25b72b360997b74392aa6c8e8bb849c01c9f069b9078f8b341361f662cf9250ed2
+
+pkgname = python2-ipwhois
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b3c732cc7df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: nosada <ngsksdt@gmail.com>
+# Python2 ver: GI_Jack <iamjacksemail@hackermail.com>
+
+pkgname=python2-ipwhois
+_pkgname=ipwhois
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Retrieve and parse whois data for IPv4 and IPv6 addresses"
+url="https://github.com/secynic/ipwhois"
+arch=(any)
+license=('MIT')
+depends=('python2' 'python2-dnspython')
+source=("https://github.com/secynic/${_pkgname}/archive/v${pkgver}.zip")
+sha512sums=('678ca8b3e9cbc41b364536f6b0e84053a0385a9238c22afcb6e860e4097e4c25b72b360997b74392aa6c8e8bb849c01c9f069b9078f8b341361f662cf9250ed2')
+
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+
+ python setup.py build
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+
+ python2 setup.py install --root=${pkgdir}
+ install -Dm644 LICENSE.txt \
+ ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+
+# vim:set ts=2 sw=2 et:
+