summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormschubert2015-06-12 12:09:31 +0100
committermschubert2015-06-12 12:09:31 +0100
commit804985df31f8a38780b2ae076f0a280233e97a9b (patch)
tree497c8857ad10f272f886e210639cc51d58ab4bb2
downloadaur-804985df31f8a38780b2ae076f0a280233e97a9b.tar.gz
Initial import
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
3 files changed, 49 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..5e0596b2b13e
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-ipython-cluster-helper
+ pkgdesc = Quickly and easily parallelize Python functions using IPython on a cluster
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/roryk/ipython-cluster-helper
+ arch = any
+ license = MIT
+ makedepends = python2-distribute
+ depends = ipython2
+ depends = python2-netifaces
+ source = https://pypi.python.org/packages/source/i/ipython-cluster-helper/ipython-cluster-helper-0.3.0.tar.gz
+
+pkgname = python2-ipython-cluster-helper
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85370209ac3e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-ipython-cluster-helper
+ pkgdesc = Quickly and easily parallelize Python functions using IPython on a cluster
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/roryk/ipython-cluster-helper
+ arch = any
+ license = MIT
+ makedepends = python2-distribute
+ depends = ipython2
+ depends = python2-netifaces
+ source = https://pypi.python.org/packages/source/i/ipython-cluster-helper/ipython-cluster-helper-0.3.0.tar.gz
+ md5sums = 8b767d535b698c6a44e299e7bcc0d5bc
+
+pkgname = python2-ipython-cluster-helper
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9365b5c375f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Michael Schubert <mschu.dev at gmail>
+
+pkgname=python2-ipython-cluster-helper
+_pkgname=${pkgname#python2-}
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Quickly and easily parallelize Python functions using IPython on a cluster"
+url="https://github.com/roryk/ipython-cluster-helper"
+license="MIT"
+depends=('ipython2' 'python2-netifaces')
+makedepends=('python2-distribute')
+arch=('any')
+source=("https://pypi.python.org/packages/source/i/$_pkgname/$_pkgname-$pkgver.tar.gz")
+md5sums=('8b767d535b698c6a44e299e7bcc0d5bc')
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}
+