summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLartza2015-07-07 14:53:52 +0300
committerLartza2015-07-07 14:53:52 +0300
commitda1b650e5b49150616251d74eb69e8758478f59a (patch)
tree176bbd61688d9c58d1ea1e2fbe6a987d1146f9e1
downloadaur-da1b650e5b49150616251d74eb69e8758478f59a.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d211e8c5d88f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-irc3
+ pkgdesc = plugable irc client library based on asyncio
+ pkgver = 0.7.1
+ pkgrel = 1
+ url = https://github.com/gawel/irc3
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-configparser
+ depends = python2-trollius
+ depends = python2-venusian
+ source = https://pypi.python.org/packages/source/i/irc3/irc3-0.7.1.zip
+ md5sums = a78f43275127b73ea61f9734d0ce491a
+
+pkgname = python2-irc3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47d6eb7c4778
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Lari Tikkanen <lartza@wippies.com>
+
+pkgname=python2-irc3
+_pkgname=irc3
+pkgver=0.7.1
+pkgrel=1
+pkgdesc="plugable irc client library based on asyncio"
+arch=(any)
+url="https://github.com/gawel/irc3"
+license=('MIT')
+depends=('python2' 'python2-configparser' 'python2-trollius' 'python2-venusian')
+makedepends=('python2-setuptools')
+source=("https://pypi.python.org/packages/source/i/irc3/irc3-$pkgver.zip")
+md5sums=('a78f43275127b73ea61f9734d0ce491a')
+
+build() {
+ cd $_pkgname-$pkgver
+ python2 setup.py build
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ python2 setup.py install --root=$pkgdir --optimize=1
+}