summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Yantis2015-06-11 08:57:56 -0700
committerJonathan Yantis2015-06-11 08:57:56 -0700
commit1d52ea7cbfcddfc9b55478771b2075c6dd4d4e86 (patch)
treea422e7b3afe60d6a58a0d6a1ffe8d926e6b27696
downloadaur-1d52ea7cbfcddfc9b55478771b2075c6dd4d4e86.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD55
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..28c6501d3ed8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-isbnlib-git
+ pkgdesc = Python 2 library to extract, clean, transform, hyphenate and get metadata for ISBN strings (based on isbntools)
+ pkgver = 3.5.6.r476.46f95b2
+ pkgrel = 2
+ url = https://github.com/xlcnd/isbnlib
+ arch = any
+ license = LGPL
+ makedepends = git
+ makedepends = python2-setuptools
+ depends = python2
+ provides = python2-isbnlib
+ conflicts = python2-isbnlib
+ source = git+https://github.com/xlcnd/isbnlib.git
+ sha256sums = SKIP
+
+pkgname = python2-isbnlib-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..954473a326d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: jyantis <yantis@yantis.net>
+
+pkgname=python2-isbnlib-git
+pkgver=3.5.6.r476.46f95b2
+pkgrel=2
+pkgdesc='Python 2 library to extract, clean, transform, hyphenate and get metadata for ISBN strings (based on isbntools)'
+arch=('any')
+url='https://github.com/xlcnd/isbnlib'
+license=('LGPL')
+depends=('python2')
+source=('git+https://github.com/xlcnd/isbnlib.git')
+sha256sums=('SKIP')
+makedepends=('git' 'python2-setuptools')
+provides=('python2-isbnlib')
+conflicts=('python2-isbnlib')
+
+pkgver() {
+ cd isbnlib
+ printf "%s." "$(grep -R "__version__ =" isbnlib/__init__.py | awk -F\' '{print $2}')"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd isbnlib
+
+ # Patch any #!/usr/bin/python to #!/usr/bin/python2
+ for file in $(find . -name '*.py' -print); do
+ sed -r -i 's_^#!.*/usr/bin/python(\s|$)_#!/usr/bin/python2_' $file
+ sed -r -i 's_^#!.*/usr/bin/env(\s)*python(\s|$)_#!/usr/bin/env python2_' $file
+ done
+
+ python2 setup.py build
+}
+
+check() {
+ cd isbnlib
+ python2 setup.py test --verbose
+}
+
+package() {
+ cd isbnlib
+
+ # We don't need anything related to git in the package
+ rm -rf .git*
+
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+
+ # Install License
+ install -D -m644 LICENSE-LGPL.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # Install Documentation
+ install -D -m644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
+}
+
+# vim:set ts=2 sw=2 et: