summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEdvinas Valatka2019-11-15 02:17:26 +0200
committerEdvinas Valatka2019-11-15 02:19:16 +0200
commit28c1909817df1baa1d25bc5394f51f96df1f16ef (patch)
tree76a602bdf59f79dfd57898f9336b9561eb551ac8
downloadaur-python2-isodate.tar.gz
Import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e054efb893c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-isodate
+ pkgdesc = An ISO 8601 date/time/duration parser and formatter
+ pkgver = 0.6.0
+ pkgrel = 3
+ url = https://github.com/gweis/isodate/
+ arch = any
+ license = BSD
+ makedepends = python2-setuptools
+ source = https://files.pythonhosted.org/packages/source/i/isodate/isodate-0.6.0.tar.gz
+ sha1sums = 2c69e08c9894a9cd96c627146463260f5731df62
+
+pkgname = python2-isodate
+ depends = python2-six
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..799cf46fe4ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor : Kyle Keen <keenerd@gmail.com>
+# Maintainer : edacval <edacval@gmail.com>
+
+pkgname=python2-isodate
+pkgver=0.6.0
+pkgrel=3
+pkgdesc="An ISO 8601 date/time/duration parser and formatter"
+arch=('any')
+url="https://github.com/gweis/isodate/"
+license=('BSD')
+makedepends=('python2-setuptools')
+source=("https://files.pythonhosted.org/packages/source/i/isodate/isodate-$pkgver.tar.gz")
+sha1sums=('2c69e08c9894a9cd96c627146463260f5731df62')
+
+
+build() {
+ cd "$srcdir/isodate-$pkgver"
+ python2 setup.py build
+}
+
+check() {
+ cd "$srcdir/isodate-$pkgver"
+ python2 setup.py test
+}
+
+package() {
+ depends=('python2-six')
+
+ cd "$srcdir/isodate-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ head -26 src/isodate/isodates.py > "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+