summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndres Urquijo2015-08-20 20:18:20 -0500
committerAndres Urquijo2015-08-20 20:18:20 -0500
commit0727da031d58730a432f06138fc3daf37a909873 (patch)
treecf2d51fb9b2c585173de78300ada82303ecfa25e
downloadaur-0727da031d58730a432f06138fc3daf37a909873.tar.gz
Adding package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5653ef9e25fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-ivisual
+ pkgdesc = IVisual provides VPython visual API for inline use in an IPython Notebook
+ pkgver = 0.1.99
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/IVisual/0.1.99
+ arch = any
+ license = GPL
+ depends = python2-vpython
+ depends = ipython2
+ source = https://pypi.python.org/packages/source/I/IVisual/IVisual-0.1.99.zip
+ md5sums = 520879c5852e619e379baa148707915d
+
+pkgname = python2-ivisual
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55a846c619ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+
+# Maintainer: Andres F. Urquijo <alfagalileox@gmail.com>
+
+pkgname=python2-ivisual
+_pkgname=IVisual
+pkgver=0.1.99
+pkgrel=1
+pkgdesc="IVisual provides VPython visual API for inline use in an IPython Notebook"
+arch=("any")
+url="https://pypi.python.org/pypi/IVisual/0.1.99"
+license=('GPL')
+depends=("python2-vpython" "ipython2")
+source="https://pypi.python.org/packages/source/I/$_pkgname/$_pkgname-$pkgver.zip"
+md5sums=("520879c5852e619e379baa148707915d")
+
+build(){
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py build
+}
+
+package(){
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+}