summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEdvinas Valatka2019-10-23 00:58:46 +0300
committerEdvinas Valatka2019-10-23 00:58:46 +0300
commit719d88ca96fe3586a51ff422556401f9794e803c (patch)
tree7faada9ff1aed1bf7bec224c47c720d61829cb45
downloadaur-719d88ca96fe3586a51ff422556401f9794e803c.tar.gz
Import from ABS
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b024e7868a73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-jdcal
+ pkgdesc = Julian dates, from proleptic Gregorian and Julian calendars
+ pkgver = 1.4.1
+ pkgrel = 1
+ url = https://github.com/phn/jdcal
+ arch = any
+ license = BSD
+ makedepends = python2-setuptools
+ source = python2-jdcal-1.4.1.tar.gz::https://github.com/phn/jdcal/archive/v1.4.1.tar.gz
+ sha256sums = 6cb87959fb9293bdd577967419af735a1a0aee3ce778c443acb219b2668c6597
+
+pkgname = python2-jdcal
+ depends = python2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a32442362ec0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Contributor: Andrzej Giniewicz <gginiu@gmail.com>
+# Contributor: Mariusz SzczepaƄczyk <mszczepanczyk@gmail.com>
+
+pkgname=python2-jdcal
+pkgver=1.4.1
+pkgrel=1
+pkgdesc="Julian dates, from proleptic Gregorian and Julian calendars"
+arch=('any')
+url="https://github.com/phn/jdcal"
+license=('BSD')
+makedepends=('python2-setuptools')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/phn/jdcal/archive/v${pkgver}.tar.gz")
+sha256sums=('6cb87959fb9293bdd577967419af735a1a0aee3ce778c443acb219b2668c6597')
+
+build() {
+ cd "$srcdir"/jdcal-${pkgver}
+ python2 setup.py build
+}
+
+package() {
+ depends=('python2')
+
+ cd "$srcdir"/jdcal-${pkgver}
+
+ python2 setup.py install --skip-build --root="$pkgdir" --optimize=1
+
+ install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}