summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDylan Baker2016-08-24 16:03:52 -0700
committerDylan Baker2016-08-24 16:59:55 -0700
commit454c96856b26c73669315869f89330784f019f35 (patch)
treecd1293ccf1b817ea69855ccf6912270d2fc03e96
downloadaur-454c96856b26c73669315869f89330784f019f35.tar.gz
Initial Commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD32
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..389b520444aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-jsonstreams
+ pkgdesc = A Python module for writing JSON as a stream
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://github.com/dcbaker/jsonstreams
+ arch = any
+ license = MIT
+ depends = python
+ optdepends = python-simplejson
+ options = !emptydirs
+ source = https://pypi.python.org/packages/b6/4e/fc68910cc9b72bca0f9ee8d8cdc7d3ef55c03ab62b2dfb9338d74639f11c/jsonstreams-0.3.1.tar.gz
+ source = https://pypi.python.org/packages/b6/4e/fc68910cc9b72bca0f9ee8d8cdc7d3ef55c03ab62b2dfb9338d74639f11c/jsonstreams-0.3.1.tar.gz.asc
+ source = https://raw.githubusercontent.com/dcbaker/jsonstreams/master/LICENSE
+ validpgpkeys = 5303CCAA8FFEE5A1472F3538089E1696140688EF
+ sha256sums = 41a7f787692fc170aff94702376cf972d1ed9678638c1b8340cb9ac15d372ed7
+ sha256sums = SKIP
+ sha256sums = 8b1cc8af45b502fd5bfce434721cb0d9a833298f05fe983ebc6c7f36d06fab59
+
+pkgname = python-jsonstreams
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..375c63b6b5df
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+
+*.tar.*
+LICENSE
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1abe616091bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Dylan Baker <dylan@pnwbakers.com>
+_name=jsonstreams
+pkgname=python-${_name}
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="A Python module for writing JSON as a stream"
+arch=('any')
+url="https://github.com/dcbaker/jsonstreams"
+license=('MIT')
+depends=('python')
+optdepends=('python-simplejson')
+options=(!emptydirs)
+source=('https://pypi.python.org/packages/b6/4e/fc68910cc9b72bca0f9ee8d8cdc7d3ef55c03ab62b2dfb9338d74639f11c/jsonstreams-0.3.1.tar.gz'
+ 'https://pypi.python.org/packages/b6/4e/fc68910cc9b72bca0f9ee8d8cdc7d3ef55c03ab62b2dfb9338d74639f11c/jsonstreams-0.3.1.tar.gz.asc'
+ 'https://raw.githubusercontent.com/dcbaker/jsonstreams/master/LICENSE')
+sha256sums=('41a7f787692fc170aff94702376cf972d1ed9678638c1b8340cb9ac15d372ed7'
+ 'SKIP'
+ '8b1cc8af45b502fd5bfce434721cb0d9a833298f05fe983ebc6c7f36d06fab59')
+validpgpkeys=('5303CCAA8FFEE5A1472F3538089E1696140688EF') # Dylan Baker <dylan@pnwbakers.com>
+
+prepare() {
+ cp LICENSE "$srcdir/${_name}-$pkgver"/
+}
+
+package() {
+ cd "$srcdir/${_name}-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: