summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Keller2016-01-04 09:04:00 -0500
committerAlexander Keller2016-01-04 09:04:00 -0500
commit5c98e23a95c79ec304638358e1553e52d756cff5 (patch)
tree69922928ca056e5fc224e99f36e17145a98686e7
downloadaur-5c98e23a95c79ec304638358e1553e52d756cff5.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a2ecec48aa77
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon Jan 4 14:03:36 UTC 2016
+pkgbase = python2-keyczar
+ pkgdesc = Toolkit for safe and simple cryptography for python2
+ pkgver = 0.715
+ pkgrel = 1
+ url = http://www.keyczar.org/
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ depends = python2
+ source = https://pypi.python.org/packages/source/p/python-keyczar/python-keyczar-0.715.tar.gz
+ md5sums = bdb47448f622fdfea7851327a5f20476
+
+pkgname = python2-keyczar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b101af5ffc94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Alexander Keller <git@nycroth.com>
+
+pkgname=python2-keyczar
+pkgver=0.715
+pkgrel=1
+pkgdesc="Toolkit for safe and simple cryptography for python2"
+url="http://www.keyczar.org/"
+arch=('i686' 'x86_64')
+license=("APACHE")
+depends=("python2")
+source=("https://pypi.python.org/packages/source/p/python-keyczar/python-keyczar-${pkgver}.tar.gz")
+md5sums=('bdb47448f622fdfea7851327a5f20476')
+
+build() {
+ cd "${srcdir}/python-keyczar-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/python-keyczar-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}