summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-06-09 11:41:58 -0700
committerAndy Weidenbaum2015-06-09 11:41:58 -0700
commite5ed9319f41c0f4d797fc28b7d91243649fb57a1 (patch)
tree7d222359d54e2d7ba0aa8aa7974867d31c4e6af7
downloadaur-e5ed9319f41c0f4d797fc28b7d91243649fb57a1.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a591d4b2bfee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-kmeans
+ pkgdesc = Python wrapper for basic C implementation of kmeans
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/numberoverzero/kmeans
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/k/kmeans/kmeans-1.0.2.tar.gz
+ md5sums = 7b042b9ea3fbe111afe920b70ee15b36
+ sha256sums = 96c4d7410bcd251e583eb2b817d133e678453d6ef7c5773f1263345eb47c24e2
+
+pkgname = python2-kmeans
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f94e066fbfb6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=python2-kmeans
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Python wrapper for basic C implementation of kmeans"
+arch=('i686' 'x86_64')
+depends=('python2')
+makedepends=('python2-setuptools')
+url="https://github.com/numberoverzero/kmeans"
+license=('MIT')
+options=(!emptydirs)
+source=(https://pypi.python.org/packages/source/k/${pkgname#python2-}/${pkgname#python2-}-$pkgver.tar.gz)
+md5sums=('7b042b9ea3fbe111afe920b70ee15b36')
+sha256sums=('96c4d7410bcd251e583eb2b817d133e678453d6ef7c5773f1263345eb47c24e2')
+
+build() {
+ cd "$srcdir/${pkgname#python2-}-$pkgver"
+
+ msg 'Building...'
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname#python2-}-$pkgver"
+
+ msg 'Installing...'
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}