summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergi Jimenez2018-05-02 11:00:58 +0200
committerSergi Jimenez2018-05-02 11:00:58 +0200
commitaacf41de6f6a21e62024e6b5ff2a89c532ea5f94 (patch)
tree7196d0c48412b7232248f8d04ccbbbbee52e1e90
downloadaur-aacf41de6f6a21e62024e6b5ff2a89c532ea5f94.tar.gz
initial import
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60d12b1bfe92
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = python2-kubernetes
+ pkgdesc = Python client for the kubernetes API
+ pkgver = 6.0.0
+ pkgrel = 1
+ url = https://github.com/kubernetes-client/python
+ arch = any
+ license = Apache
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-certifi
+ depends = python2-six
+ depends = python2-dateutil
+ depends = python2-urllib3
+ depends = python2-yaml
+ depends = python2-google-auth
+ depends = python2-ipaddress
+ depends = python2-websocket-client
+ depends = python2-requests
+ depends = python2-requests-oauthlib
+ source = https://files.pythonhosted.org/packages/source/k/kubernetes/kubernetes-6.0.0.tar.gz
+ sha256sums = b370ab4abd925309db69a14a4723487948e9a83de60ca92782ec14992b741c89
+
+pkgname = python2-kubernetes
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..df8c135af105
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+**.tar.gz
+**.tar.xz
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..036e5cce28c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Sergi Jimenez <sjr@redhat.com>
+
+pkgname=python2-kubernetes
+_pkgname=kubernetes
+pkgver=6.0.0
+pkgrel=1
+license=('Apache')
+pkgdesc='Python client for the kubernetes API'
+makedepends=('python2-setuptools')
+depends=('python2'
+ 'python2-certifi'
+ 'python2-six'
+ 'python2-dateutil'
+ 'python2-urllib3'
+ 'python2-yaml'
+ 'python2-google-auth'
+ 'python2-ipaddress'
+ 'python2-websocket-client'
+ 'python2-requests'
+ 'python2-requests-oauthlib')
+arch=('any')
+url='https://github.com/kubernetes-client/python'
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('b370ab4abd925309db69a14a4723487948e9a83de60ca92782ec14992b741c89')
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}