summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorg Schlisio2016-04-19 17:56:29 +0200
committerGeorg Schlisio2016-04-19 17:56:29 +0200
commit7e536a4dbae1612e104fca667af36d30d5127c91 (patch)
tree062da5ea3b6fc95b2c9610e000f10e38b697fe17
downloadaur-7e536a4dbae1612e104fca667af36d30d5127c91.tar.gz
initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
-rw-r--r--setup.py7
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..645fa4d7a5d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-ldnsx
+ pkgdesc = python ldns API for human beings
+ pkgver = 2012.01.25
+ pkgrel = 1
+ url = https://github.com/colah/ldnsx
+ arch = any
+ license = BSD
+ makedepends = git
+ depends = python2-setuptools
+ source = ldnsx::git+https://github.com/colah/ldnsx.git
+ source = setup.py
+ md5sums = SKIP
+ md5sums = 6e089423ad004726b55c761e8f4b05de
+
+pkgname = python2-ldnsx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d18a60ef7ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: fordprefect <fordprefect@dukun.de>
+pkgname=python2-ldnsx
+pkgver=2012.01.25
+pkgrel=1
+pkgdesc="python ldns API for human beings"
+url="https://github.com/colah/ldnsx"
+arch=('any')
+license=('BSD')
+depends=("python2-setuptools")
+makedepends=("git")
+#optdepends=("")
+source=("ldnsx::git+https://github.com/colah/ldnsx.git"
+ "setup.py")
+md5sums=('SKIP'
+ '6e089423ad004726b55c761e8f4b05de')
+
+package() {
+ cd "${srcdir}/ldnsx"
+ git checkout 5f7f8fa2ddb94b2db13875ec9dae3ed7549b938a 2&> /dev/null || true
+ cp ../../setup.py .
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+}
diff --git a/setup.py b/setup.py
new file mode 100644
index 000000000000..8d40c96cb7b4
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,7 @@
+from distutils.core import setup
+setup(name='ldnsx',
+ version='0.0.0',
+ py_modules=['ldnsx'],
+ description="",
+ author="Christopher Olah",
+ )