summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-12-13 02:14:18 +0100
committerM0Rf302015-12-13 02:14:18 +0100
commit71899a171171bcb2f9d6be10d6797e7e660e3174 (patch)
tree4e5d8d08940e9c58475e18f239f0ea0f468b982c
downloadaur-71899a171171bcb2f9d6be10d6797e7e660e3174.tar.gz
first commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD21
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..766aceeb6eb2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Dec 13 01:14:11 UTC 2015
+pkgbase = python2-libbitcoinclient
+ pkgdesc = Pure Python Obelisk + Bitcoin client side library
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/OpenBazaar/python-libbitcoinclient
+ arch = any
+ license = AGPL
+ makedepends = python2-setuptools
+ depends = python2-ecdsa
+ depends = python2-twisted
+ depends = python2-pyzmq
+ conflicts = python2-obelisk
+ replaces = python2-obelisk
+ source = https://github.com/OpenBazaar/python-libbitcoinclient/archive/0.3.0.tar.gz
+ md5sums = c7143ef7813c66e7e5768b8d889d0b5e
+
+pkgname = python2-libbitcoinclient
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60b129b670f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: M0Rf30
+
+pkgname=python2-libbitcoinclient
+pkgver=0.3.0
+pkgrel=1
+pkgdesc='Pure Python Obelisk + Bitcoin client side library'
+arch=('any')
+url='https://github.com/OpenBazaar/python-libbitcoinclient'
+license=('AGPL')
+depends=(python2-ecdsa python2-twisted python2-pyzmq)
+makedepends=(python2-setuptools)
+conflicts=(python2-obelisk)
+replaces=(python2-obelisk)
+source=("https://github.com/OpenBazaar/python-libbitcoinclient/archive/$pkgver.tar.gz")
+
+package() {
+ cd "$srcdir/python-libbitcoinclient-$pkgver"
+ python2 setup.py install --root="$pkgdir" -O1
+}
+
+md5sums=('c7143ef7813c66e7e5768b8d889d0b5e')