summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlivier Medoc2016-03-15 10:38:21 +0000
committerOlivier Medoc2016-03-15 10:38:21 +0000
commit2084c977d8678323251134b7a37be19e15f44345 (patch)
tree44e019a62e526400c6142e801d88b0890e1f3b25
downloadaur-python2-libesedb.tar.gz
Initial Commit
-rw-r--r--.SRCINFO15
-rwxr-xr-xPKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26e38eed1ae2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-libesedb
+ pkgdesc = Library and tools to access the Extensible Storage Engine (ESE) Database File (EDB) format.
+ pkgver = 20151205
+ pkgrel = 1
+ url = https://github.com/libyal/libesedb/
+ arch = any
+ license = LGPLv3+
+ makedepends = python2
+ makedepends = gcc
+ depends = python2
+ source = https://pypi.python.org/packages/source/l/libesedb-python/libesedb-python-20151205.tar.gz#md5=63c0a8f64dfb07fd6571633e7f34919f
+ md5sums = 63c0a8f64dfb07fd6571633e7f34919f
+
+pkgname = python2-libesedb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..e9c279d89331
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=python2-libesedb
+_pkgcode=libesedb
+pkgver=20151205
+pkgrel=1
+pkgdesc=" Library and tools to access the Extensible Storage Engine (ESE) Database File (EDB) format."
+url="https://github.com/libyal/libesedb/"
+arch=('any')
+license=('LGPLv3+')
+
+depends=('python2')
+makedepends=('python2' 'gcc')
+
+md5sum=63c0a8f64dfb07fd6571633e7f34919f
+source=(https://pypi.python.org/packages/source/l/$_pkgcode-python/$_pkgcode-python-$pkgver.tar.gz#md5=$md5sum)
+md5sums=($md5sum)
+
+build() {
+ cd $srcdir/${_pkgcode}-${pkgver}
+
+ python2 setup.py build
+}
+
+package() {
+ cd $srcdir/${_pkgcode}-${pkgver}
+ python2 setup.py install --root="${pkgdir}"
+}