summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-06-10 14:27:16 -0500
committerCarlos Aznarán Laos2022-06-10 14:27:16 -0500
commit80a9c2b003e0f72f1fb648e8a667b0314aa61568 (patch)
tree51cec0fceb2fcf634a34df407de65d6144408f28
parent4560b4645f747c3a125d13276c23d5f959e236a8 (diff)
downloadaur-python2-liblnk.tar.gz
Bump version to 20210417
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rwxr-xr-xPKGBUILD34
3 files changed, 23 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 243d9996c8a1..09c0b166eabd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = python2-liblnk
pkgdesc = Library and tools to access the Windows Shortcut File (LNK) format
- pkgver = 20151205
+ pkgver = 20210417
pkgrel = 1
- url = https://github.com/libyal/liblnk/
+ url = https://github.com/libyal/liblnk
arch = any
- license = LGPLv3+
- makedepends = python2
+ license = LGPL
+ makedepends = python2-setuptools
makedepends = gcc
depends = python2
- source = https://pypi.python.org/packages/source/l/liblnk-python/liblnk-python-20151205.tar.gz#md5=e1bc3423fb60fc4d365e2ab094b97a39
- md5sums = e1bc3423fb60fc4d365e2ab094b97a39
+ source = https://pypi.org/packages/source/l/liblnk-python/liblnk-python-20210417.tar.gz
+ sha512sums = d39d4225ee15da850a5b280a5483331a0d5772dbdfd815eee61b4dd29d6a27f10e2b8cad10e43224d790fa864c0512fce43725a7b8ccabc5ee8deb4705cfa2cb
pkgname = python2-liblnk
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index cf58ded8fe1a..2760158182fc 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,24 @@
-pkgname=python2-liblnk
-_pkgcode=liblnk
-pkgver=20151205
+# Contributor: Olivier Medoc <o_medoc@yahoo.fr>
+_base=liblnk
+pkgname=python2-${_base}
+pkgver=20210417
pkgrel=1
-pkgdesc="Library and tools to access the Windows Shortcut File (LNK) format"
-url="https://github.com/libyal/liblnk/"
-arch=('any')
-license=('LGPLv3+')
-
-depends=('python2')
-makedepends=('python2' 'gcc')
-
-md5sum=e1bc3423fb60fc4d365e2ab094b97a39
-source=(https://pypi.python.org/packages/source/l/$_pkgcode-python/$_pkgcode-python-$pkgver.tar.gz#md5=$md5sum)
-md5sums=($md5sum)
+pkgdesc="Library and tools to access the Windows Shortcut File (LNK) format"
+url="https://github.com/libyal/${_base}"
+arch=(any)
+license=(LGPL)
+depends=(python2)
+makedepends=(python2-setuptools gcc)
+source=(https://pypi.org/packages/source/${_base::1}/${_base}-python/${_base}-python-${pkgver}.tar.gz)
+sha512sums=('d39d4225ee15da850a5b280a5483331a0d5772dbdfd815eee61b4dd29d6a27f10e2b8cad10e43224d790fa864c0512fce43725a7b8ccabc5ee8deb4705cfa2cb')
build() {
- cd $srcdir/${_pkgcode}-${pkgver}
-
+ cd ${_base}-${pkgver}
python2 setup.py build
}
package() {
- cd $srcdir/${_pkgcode}-${pkgver}
- python2 setup.py install --root="${pkgdir}"
+ cd ${_base}-${pkgver}
+ python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
}