summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-06-10 14:04:33 -0500
committerCarlos Aznarán Laos2022-06-10 14:04:33 -0500
commit3b6aed3c60b5d593b24b8af5564160c7071a72e4 (patch)
treefd214ee377bb765d9e622d644b01e03f4eaa99d8
parentdcfa278b1f34dd5d0813d2ba99a338cc24cd3a28 (diff)
downloadaur-3b6aed3c60b5d593b24b8af5564160c7071a72e4.tar.gz
Bump version to 20210425
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rwxr-xr-xPKGBUILD34
3 files changed, 23 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 857ccd3a9b49..4c1dad457a1c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = python2-libvhdi
pkgdesc = Library and tools to access the Virtual Hard Disk (VHD) image format
- pkgver = 20151220
+ pkgver = 20210425
pkgrel = 1
- url = https://github.com/libyal/libvhdi/
+ url = https://github.com/libyal/libvhdi
arch = any
- license = LGPLv3+
- makedepends = python2
+ license = LGPL
+ makedepends = python2-setuptools
makedepends = gcc
depends = python2
- source = https://pypi.python.org/packages/source/l/libvhdi-python/libvhdi-python-20151220.tar.gz#md5=d7e90dce45125825519b16c86d3fb3be
- md5sums = d7e90dce45125825519b16c86d3fb3be
+ source = https://pypi.org/packages/source/l/libvhdi-python/libvhdi-python-20210425.tar.gz
+ sha512sums = 105c0a6b8cf5d0202e219e87932887651f66ad9c14be000499dd9a35e8d314704cce6d74afc61044522e0c69576c094bfce4a4ad1a6258bc958229825b58c479
pkgname = python2-libvhdi
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 617e001d95d3..78f6e49032b7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,24 @@
-pkgname=python2-libvhdi
-_pkgcode=libvhdi
-pkgver=20151220
+# Contributor: Olivier Medoc <o_medoc@yahoo.fr>
+_base=libvhdi
+pkgname=python2-${_base}
+pkgver=20210425
pkgrel=1
-pkgdesc="Library and tools to access the Virtual Hard Disk (VHD) image format"
-url="https://github.com/libyal/libvhdi/"
-arch=('any')
-license=('LGPLv3+')
-
-depends=('python2')
-makedepends=('python2' 'gcc')
-
-md5sum=d7e90dce45125825519b16c86d3fb3be
-source=(https://pypi.python.org/packages/source/l/$_pkgcode-python/$_pkgcode-python-$pkgver.tar.gz#md5=$md5sum)
-md5sums=($md5sum)
+pkgdesc="Library and tools to access the Virtual Hard Disk (VHD) image format"
+url="https://github.com/libyal/${_base}"
+arch=(any)
+license=(LGPL)
+depends=(python2)
+makedepends=(python2-setuptools gcc)
+source=(https://pypi.org/packages/source/${_base::1}/${_base}-python/${_base}-python-${pkgver}.tar.gz)
+sha512sums=('105c0a6b8cf5d0202e219e87932887651f66ad9c14be000499dd9a35e8d314704cce6d74afc61044522e0c69576c094bfce4a4ad1a6258bc958229825b58c479')
build() {
- cd $srcdir/${_pkgcode}-${pkgver}
-
+ cd ${_base}-${pkgver}
python2 setup.py build
}
package() {
- cd $srcdir/${_pkgcode}-${pkgver}
- python2 setup.py install --root="${pkgdir}"
+ cd ${_base}-${pkgver}
+ python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
}