summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinuxSEAT2018-07-18 14:16:46 +0300
committerlinuxSEAT2018-07-18 14:16:46 +0300
commitfcf48764b865859e986c85df42c054a0411805ca (patch)
treebafeb3c08351c74b371a77097cc18c9ec346cd51
downloadaur-fcf48764b865859e986c85df42c054a0411805ca.tar.gz
initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bb918a70dfdb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-libvslvm
+ pkgdesc = library to access the Linux Logical Volume Manager (LVM)
+ pkgver = 20160110
+ pkgrel = 1
+ url = https://github.com/libyal/libvslvm
+ arch = any
+ license = LGPL
+ makedepends = python2-setuptools
+ depends = python2
+ options = !emptydirs
+ source = https://github.com/libyal/libvslvm/releases/download/20160110/libvslvm-experimental-20160110.tar.gz
+ md5sums = 03c3e53b5817e9e9ec2e0bc107ebc733
+
+pkgname = python2-libvslvm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a54531a69943
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: linuxSEAT <--put_my_name_here--@gmail.com>
+
+pkgname=python2-libvslvm
+_pkgname=libvslvm
+pkgver=20160110
+pkgrel=1
+pkgdesc="library to access the Linux Logical Volume Manager (LVM)"
+arch=('any')
+url="https://github.com/libyal/libvslvm"
+license=('LGPL')
+groups=()
+depends=( 'python2')
+makedepends=('python2-setuptools')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=(https://github.com/libyal/$_pkgname/releases/download/$pkgver/$_pkgname-experimental-$pkgver.tar.gz)
+md5sums=('03c3e53b5817e9e9ec2e0bc107ebc733')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+
+# vim:set ts=2 sw=2 et: