summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJanne Heß2016-01-15 19:16:22 +0100
committerJanne Heß2016-01-15 19:16:22 +0100
commit3a7baf4c04d22fe75003facc438ecf4203ac8229 (patch)
tree3559f8075bbf9e2b82636c4b72fc56c9067cbcf3
downloadaur-3a7baf4c04d22fe75003facc438ecf4203ac8229.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d851f2b5ce7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Jan 15 18:15:45 UTC 2016
+pkgbase = python2-libzfs-git
+ pkgdesc = Python CFFI bindings for libzfs
+ pkgver = 89d28d7
+ pkgrel = 1
+ url = https://github.com/Xaroth/libzfs-python
+ arch = i386
+ arch = x86_64
+ license = MIT
+ makedepends = gcc
+ depends = python2-cffi
+ depends = python2-enum34
+ source = git://github.com/kelleyk/libzfs-python
+ sha256sums = SKIP
+
+pkgname = python2-libzfs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..357730dd3943
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Janne Heß <jannehess@gmail.com>
+
+# Contributor: Janne Heß <jannehess@gmail.com>
+
+pkgname=python2-libzfs-git
+pkgver=89d28d7
+pkgrel=1
+pkgdesc='Python CFFI bindings for libzfs'
+url='https://github.com/Xaroth/libzfs-python'
+license=('MIT')
+depends=('python2-cffi' 'python2-enum34')
+makedepends=('gcc')
+source=('git://github.com/kelleyk/libzfs-python')
+sha256sums=('SKIP')
+arch=('i386' 'x86_64')
+
+pkgver() {
+ cd "${srcdir}/libzfs-python"
+ git describe --always
+}
+
+package() {
+ cd "${srcdir}/libzfs-python"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+ # WTF These comments contain absolute paths
+ sed -i 's/^# .*$//g' "${pkgdir}/usr/lib/python2.7/site-packages/libzfs/bindings/output/headers.h.in"
+}
+