summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Kitching2018-07-12 04:21:46 +0100
committerChris Kitching2018-07-12 04:21:46 +0100
commit3bbcacde0d57f12fd2b8a091b4914ec0403eeb81 (patch)
tree3ee3e87bb83661d8292b23092bd43e808d502af6
downloadaur-3bbcacde0d57f12fd2b8a091b4914ec0403eeb81.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9397fac7743d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+# Generated by mksrcinfo v8
+# Thu Jul 12 03:21:42 UTC 2018
+pkgbase = python2-lnt-git
+ pkgdesc = LLVM nightly test infrastructure
+ pkgver = r1796.1384b08
+ pkgrel = 1
+ arch = x86_64
+ depends = python2
+ source = git+https://github.com/llvm-mirror/lnt.git
+ md5sums = SKIP
+
+pkgname = python2-lnt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46e76d3da223
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Chris Kitching <chriskitching@linux.com>
+
+pkgname=python2-lnt-git
+pkgver=r1796.1384b08
+pkgrel=1
+pkgdesc="LLVM nightly test infrastructure"
+arch=('x86_64')
+depends=(python2)
+source=('git+https://github.com/llvm-mirror/lnt.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "lnt"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "lnt"
+ python2 setup.py build
+}
+
+package() {
+ cd "lnt"
+ python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}