summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2015-09-12 04:09:48 -0400
committerChris Severance2015-09-12 04:09:48 -0400
commitab69d07b92f25d55c36f4618d0c61592f64516c8 (patch)
tree131117891ec64ddd349b442b8cd4174074763262
downloadaur-ab69d07b92f25d55c36f4618d0c61592f64516c8.tar.gz
Initial Import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..43f6409ab181
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-lshell
+ pkgdesc = Limited Shell, lets you restrict a user's environment to limited sets of commands, and more
+ pkgver = 0.9.17
+ pkgrel = 1
+ url = https://github.com/ghantoos/lshell
+ arch = any
+ license = GPL
+ makedepends = python2
+ makedepends = python2-distribute
+ backup = etc/lshell.conf
+ source = lshell-0.9.17.tar.gz::https://github.com/ghantoos/lshell/archive/0.9.17.tar.gz
+ sha256sums = e3ec1dad37e8da192604ee39f83d26acc8c8e8a227a8ba216e9caaa6abd7809d
+
+pkgname = python2-lshell
+ depends = python2
+ conflicts = lshell
+ conflicts = python-lshell
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e3d27facb4dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: Roel Blaauwgeers <roel at ttys0.nl>
+# Contributor: Archme <archme.mail@gmail.com>
+
+set -u
+_pyver="python2"
+_pybase='lshell'
+_pyverother='python python2 '
+_pyverother=(${_pyverother//${_pyver} /})
+pkgname="${_pyver}-${_pybase}"
+pkgver='0.9.17'
+pkgrel='1'
+pkgdesc="Limited Shell, lets you restrict a user's environment to limited sets of commands, and more"
+arch=('any')
+license=('GPL')
+#url='http://lshell.ghantoos.org/'
+url="https://github.com/ghantoos/${_pybase}"
+backup=('etc/lshell.conf')
+makedepends=("${_pyver}" "${_pyver}-distribute") # same as python-setuptools
+_srcdir="${_pybase}-${pkgver}"
+_verwatch=("${url}/releases" "${url#*github.com}/archive/\(.*\)\.tar\.gz" 'l')
+source=("${_pybase}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+#source=("${pkgname}-${pkgver}.tar.gz::https://sourceforge.net/projects/${pkgname}/files/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz/download")
+sha256sums=('e3ec1dad37e8da192604ee39f83d26acc8c8e8a227a8ba216e9caaa6abd7809d')
+
+package() {
+ set -u
+ depends=("${_pyver}") # "${_pydepends[@]}")
+ conflicts=("${_pybase}" "${_pyverother[@]/%/-${_pybase}}")
+ cd "${_srcdir}"
+ ${_pyver} setup.py install --root="${pkgdir}" --optimize=1
+ install -Dpm644 'COPYING' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ set +u
+}
+set +u
+
+# vim:set ts=2 sw=2 et: