summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2023-06-25 23:54:39 +0200
committerPellegrino Prevete2023-06-25 23:54:39 +0200
commit6bca91736ce81b0920bc5f285b636575d21a1f01 (patch)
tree833fb7ef1229d37318118d3e715cc33108135711
parent759026d9359f23763e6eea9269619e2a47bd96c5 (diff)
downloadaur-6bca91736ce81b0920bc5f285b636575d21a1f01.tar.gz
upgrade to 2.02.188
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD46
2 files changed, 38 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d744242909b..9eb7e2b71f7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
-# Generated by mksrcinfo v8
-# Fri Aug 30 23:07:56 UTC 2019
pkgbase = python2-lvm
pkgdesc = Python 2 bindings for LVM
- pkgver = 2.02.186
+ pkgver = 2.02.188
pkgrel = 1
- url = http://sourceware.org/lvm2/
+ url = http://sourceware.org/lvm
arch = i686
arch = x86_64
license = LGPL2.1
depends = python2
depends = lvm2
- source = https://ftp.gwdg.de/pub/linux/sources.redhat.com/lvm2/LVM2.2.02.186.tgz
- source = https://ftp.gwdg.de/pub/linux/sources.redhat.com/lvm2/LVM2.2.02.186.tgz.asc
- sha256sums = d8421eee702982dc0d8b0c9e40cc1443ee487eff1460a00244a9f4bf439a27be
+ source = https://ftp.gwdg.de/pub/linux/sources.redhat.com/lvm2/LVM2.2.02.188.tgz
+ source = https://ftp.gwdg.de/pub/linux/sources.redhat.com/lvm2/LVM2.2.02.188.tgz.asc
+ validpgpkeys = 88437EF5C077BD113D3B7224228191C1567E2C17
+ validpgpkeys = D501A478440AE2FD130A1BE8B9112431E509039F
+ sha256sums = 7101e8b0816ad77e4390fed9749a090214ba520061cd083437871e19e50cc9bd
sha256sums = SKIP
pkgname = python2-lvm
-
diff --git a/PKGBUILD b/PKGBUILD
index c41db3b6d19a..0f2f020c5353 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,45 @@
-# Maintainer: Baptiste Jonglez <baptiste--aur at jonglez dot org>
-# Based on the lvm2 package in [core]
-pkgname="python2-lvm"
-pkgver=2.02.186
+# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete at gmail dot com>
+# Contributor: Baptiste Jonglez <baptiste--aur at jonglez dot org>
+
+_py="python2"
+_pkg="lvm"
+pkgname="${_py}-${_pkg}"
+pkgver=2.02.188
pkgrel=1
-arch=('i686' 'x86_64')
-url="http://sourceware.org/lvm2/"
+arch=(
+ i686
+ x86_64)
+url="http://sourceware.org/${_pkg}"
license=('LGPL2.1')
pkgdesc="Python 2 bindings for LVM"
-depends=('python2' 'lvm2')
-source=("https://ftp.gwdg.de/pub/linux/sources.redhat.com/lvm2/LVM2.${pkgver}.tgz"{,.asc})
-sha256sums=('d8421eee702982dc0d8b0c9e40cc1443ee487eff1460a00244a9f4bf439a27be'
+depends=(
+ "${_py}"
+ "${_pkg}2")
+_repo_url="https://ftp.gwdg.de/pub/linux/sources.redhat.com"
+source=("${_repo_url}/${_pkg}2/LVM2.${pkgver}.tgz"{,.asc})
+sha256sums=('7101e8b0816ad77e4390fed9749a090214ba520061cd083437871e19e50cc9bd'
'SKIP')
validpgpkeys=('88437EF5C077BD113D3B7224228191C1567E2C17' # Alasdair G Kergon <agk@redhat.com>
'D501A478440AE2FD130A1BE8B9112431E509039F') # Marian Csontos <mcsontos@redhat.com>
build() {
- local _CONFIGUREOPTS="--prefix=/usr --sysconfdir=/etc --localstatedir=/var --sbindir=/usr/bin \
- --with-udev-prefix=/usr --with-systemdsystemunitdir=/usr/lib/systemd/system \
- --with-default-pid-dir=/run --with-default-dm-run-dir=/run --with-default-run-dir=/run/lvm \
- --with-default-locking-dir=/run/lock/lvm \
- --enable-applib --enable-python2_bindings"
+ local _configure_opts=(
+ '--prefix=/usr'
+ '--sysconfdir=/etc'
+ '--localstatedir=/var'
+ '--sbindir=/usr/bin'
+ '--with-udev-prefix=/usr'
+ '--with-systemdsystemunitdir=/usr/lib/systemd/system'
+ '--with-default-pid-dir=/run'
+ '--with-default-dm-run-dir=/run'
+ '--with-default-run-dir=/run/lvm'
+ '--with-default-locking-dir=/run/lock/lvm'
+ '--enable-applib'
+ '--enable-python2_bindings')
cd LVM2.${pkgver}
- ./configure ${_CONFIGUREOPTS}
+ ./configure "${_configure_opts[@]}"
make python
}