summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2022-05-31 08:39:32 -0400
committerPatrick Northon2022-05-31 08:39:32 -0400
commit2af0c9d4021944326a1e14dd4e8e11a3fe0ed699 (patch)
tree11ca0da518d64e21739a842d4b3bc394fc77cbd3
parentddd4f33c3994b37501b13e7f5980fc846943119b (diff)
downloadaur-2af0c9d4021944326a1e14dd4e8e11a3fe0ed699.tar.gz
Cleanup
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 37d2de2d0979..2aead0e1b8c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@ pkgname=python2-lxml
pkgver=4.9.0_2
_pkgver=${pkgver//_/-}
pkgrel=1
-pkgdesc="Python2 binding for the libxml2 and libxslt libraries"
+pkgdesc='Python2 binding for the libxml2 and libxslt libraries'
arch=('i686' 'x86_64' 'armv7h')
-url="https://lxml.de/"
+url='https://lxml.de/'
license=('BSD' 'custom')
depends=('python2' 'libxslt')
makedepends=('python2-setuptools' 'cython2')
@@ -15,14 +15,14 @@ sha512sums=('ef11f51cb682fb42dff0cd024de1f7e52c95dfae403a6914e8246f36ffdb110120d
_dir="lxml-lxml-${_pkgver}"
build() {
- cd "${_dir}"
- python2 setup.py build
+ cd "${_dir}"
+ python2 setup.py build
}
package() {
- cd "${_dir}"
+ cd "${_dir}"
python2 setup.py install --root "${pkgdir}" --prefix=/usr --optimize=1 --skip-build
-
+
install -Dm644 'LICENSES.txt' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 'doc/licenses/BSD.txt' "$pkgdir/usr/share/licenses/$pkgname/BSD.txt"
install -Dm644 'doc/licenses/elementtree.txt' "$pkgdir/usr/share/licenses/$pkgname/elementtree.txt"