summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2020-05-23 14:04:50 +0200
committerXiretza2020-05-23 14:04:50 +0200
commit12688c9812e273fc11f9685b6bcd98bdf02a37b7 (patch)
treead86c3b0f6828c2acfebf109d5f1f2bb67e22290
downloadaur-12688c9812e273fc11f9685b6bcd98bdf02a37b7.tar.gz
Initial import
Based on the last version of the repo package with python2 support: https://git.archlinux.org/svntogit/packages.git/tree/trunk?h=packages/python-mako&id=f40d9862d3aac9805e1802faf73cd3880084536e
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f8039195ae8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python2-mako
+ pkgdesc = A super-fast templating language that borrows the best ideas from the existing templating languages
+ pkgver = 1.1.2
+ pkgrel = 3
+ url = https://www.makotemplates.org/
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2-markupsafe
+ depends = python2-beaker
+ depends = python2-setuptools
+ source = https://pypi.io/packages/source/M/Mako/Mako-1.1.2.tar.gz
+ source = https://pypi.io/packages/source/M/Mako/Mako-1.1.2.tar.gz.asc
+ validpgpkeys = 83AF7ACE251C13E6BB7DEFBD330239C1C4DAFEE1
+ sha512sums = 73b7a32ceb6e39dc2491734546c83a752bf0c8bc7546bb236801c02a5bccc5b59f2440333a328ff747eee936612dd12279f08d27d76f065fd589081d232692a8
+ sha512sums = SKIP
+
+pkgname = python2-mako
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa527576854b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+
+pkgname=python2-mako
+pkgver=1.1.2
+pkgrel=3
+pkgdesc="A super-fast templating language that borrows the best ideas from the existing templating languages"
+arch=('any')
+url="https://www.makotemplates.org/"
+license=('MIT')
+makedepends=('python2-setuptools')
+depends=('python2-markupsafe' 'python2-beaker' 'python2-setuptools')
+
+source=("https://pypi.io/packages/source/M/Mako/Mako-$pkgver.tar.gz"{,.asc})
+sha512sums=('73b7a32ceb6e39dc2491734546c83a752bf0c8bc7546bb236801c02a5bccc5b59f2440333a328ff747eee936612dd12279f08d27d76f065fd589081d232692a8'
+ 'SKIP')
+validpgpkeys=('83AF7ACE251C13E6BB7DEFBD330239C1C4DAFEE1') # Michael Bayer
+
+build() {
+ cd "$srcdir/Mako-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/Mako-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ mv "$pkgdir"/usr/bin/mako-render{,2}
+}