summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-06-12 14:14:31 +0200
committerMarcell Meszaros2022-06-12 14:14:31 +0200
commit1483d012e2f24adeabfbf8ed7a5bb4f5fd83d914 (patch)
treefc85ca6e1a74c02e882364a61c2a8f4370b85e94
parentf6c8ab0372e348229111365e39b2c77574815da5 (diff)
downloadaur-1483d012e2f24adeabfbf8ed7a5bb4f5fd83d914.tar.gz
updpkg 1.1.6
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD39
3 files changed, 39 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5683ce9060c5..58655418cf8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = python2-mako
- pkgdesc = A super-fast templating language that borrows the best ideas from the existing templating languages
- pkgver = 1.1.5
+ pkgdesc = A fast templating language that borrows the best ideas from other templating languages
+ pkgver = 1.1.6
pkgrel = 1
- url = https://www.makotemplates.org/
+ url = https://pypi.org/project/Mako/1.1.6/
arch = any
license = MIT
makedepends = python2-setuptools
- depends = python2-markupsafe
depends = python2-beaker
- depends = python2-setuptools
- source = https://pypi.io/packages/source/M/Mako/Mako-1.1.5.tar.gz
- source = https://pypi.io/packages/source/M/Mako/Mako-1.1.5.tar.gz.asc
+ depends = python2-markupsafe
+ source = https://pypi.python.org/packages/source/M/Mako/Mako-1.1.6.tar.gz
+ source = https://pypi.python.org/packages/source/M/Mako/Mako-1.1.6.tar.gz.asc
validpgpkeys = 83AF7ACE251C13E6BB7DEFBD330239C1C4DAFEE1
- sha512sums = 3eff75f1a94f8e01131ce118df73be1ade79306562ae2ca68079eb2b64ef82c48c09cfd7ed6eda42819bf50c70941cf4115f8918b4d8187f7489717c7d4a423b
- sha512sums = SKIP
+ b2sums = bbdf0db9303f5d369b5c6c6644ee44d767630f51305ae259c44c65a3fba959a07d9833fdc69fc8168f7424cc0c3a05e991daae239bef8392c01396c1295967c7
+ b2sums = SKIP
pkgname = python2-mako
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..33f4e24f5b6e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!*.diff
+!*.hook
+!*.install
+!*.patch
diff --git a/PKGBUILD b/PKGBUILD
index 11724d64b346..f0b8909ffa03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,37 @@
-# Maintainer: Daniel Langbein < daniel [ at ] systemli [ dot ] org >
+# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
+# Contributor: Daniel Langbein < daniel [ at ] systemli [ dot ] org >
# Contributor: Felix Yan <felixonmars@archlinux.org>
-pkgname=python2-mako
-pkgver=1.1.5
+pkgname='python2-mako'
+_name='Mako'
+pkgver=1.1.6
pkgrel=1
-pkgdesc="A super-fast templating language that borrows the best ideas from the existing templating languages"
+pkgdesc='A fast templating language that borrows the best ideas from other templating languages'
arch=('any')
-url="https://www.makotemplates.org/"
+url="https://pypi.org/project/${_name}/${pkgver}/"
license=('MIT')
-makedepends=('python2-setuptools')
-depends=('python2-markupsafe' 'python2-beaker' 'python2-setuptools')
-
-source=("https://pypi.io/packages/source/M/Mako/Mako-$pkgver.tar.gz"{,.asc})
-sha512sums=('3eff75f1a94f8e01131ce118df73be1ade79306562ae2ca68079eb2b64ef82c48c09cfd7ed6eda42819bf50c70941cf4115f8918b4d8187f7489717c7d4a423b'
- 'SKIP')
+depends=(
+ 'python2-beaker'
+ 'python2-markupsafe'
+)
+makedepends=(
+ 'python2-setuptools'
+)
+_tarname="${_name}-${pkgver}"
+source=("https://pypi.python.org/packages/source/${_name::1}/${_name}/${_tarname}.tar.gz"{,.asc})
+b2sums=('bbdf0db9303f5d369b5c6c6644ee44d767630f51305ae259c44c65a3fba959a07d9833fdc69fc8168f7424cc0c3a05e991daae239bef8392c01396c1295967c7'
+ 'SKIP')
validpgpkeys=('83AF7ACE251C13E6BB7DEFBD330239C1C4DAFEE1') # Michael Bayer
build() {
- cd "$srcdir/Mako-$pkgver"
+ cd "${_tarname}"
python2 setup.py build
}
package() {
- cd "$srcdir/Mako-$pkgver"
- python2 setup.py install --root="$pkgdir" --optimize=1
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "${_tarname}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
- mv "$pkgdir"/usr/bin/mako-render{,2}
+ mv "${pkgdir}/usr/bin/mako-render"{,2}
}