summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-06-12 13:57:14 +0200
committerMarcell Meszaros2022-06-12 13:57:14 +0200
commit8bfdb0e7f1a5d53b0b946c5c1de243c4e6b33217 (patch)
treec453e80e6fa2f76db2c47452226979be2a726663
parent82bcc8d8fed6b9b4bb7d01f86cae75a38bb5ece5 (diff)
downloadaur-8bfdb0e7f1a5d53b0b946c5c1de243c4e6b33217.tar.gz
disable tests (via python2-pytest-runner) because it's got dropped from repos
-rw-r--r--.SRCINFO11
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore22
-rw-r--r--PKGBUILD37
4 files changed, 29 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d76b037b77e1..4faea3a66f9b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = python2-markupsafe
- pkgdesc = Implements a XML/HTML/XHTML Markup safe string for Python - python2 version
+ pkgdesc = Safely add untrusted strings to HTML/XML markup
pkgver = 1.1.1
- pkgrel = 8
- url = https://pypi.python.org/pypi/MarkupSafe
+ pkgrel = 9
+ url = https://pypi.python.org/pypi/MarkupSafe/1.1.1
arch = x86_64
license = BSD
- checkdepends = python2-pytest-runner
makedepends = python2-setuptools
depends = python2
- source = python2-markupsafe-1.1.1-8.tar.gz::https://github.com/pallets/markupsafe/archive/1.1.1.tar.gz
- sha256sums = 222a10e3237d92a9cd45ed5ea882626bc72bc5e0264d3ed0f2c9129fa69fc167
+ source = MarkupSafe-1.1.1.tar.gz::https://pypi.python.org/packages/source/M/MarkupSafe/MarkupSafe-1.1.1.tar.gz
+ b2sums = 184ab0bc42f8d254ef4239f700f019c0a380bdf2117dfe1abe2eb4dfa0f037158d181a120d8654a6971e9c8badb078f997e3a8bf231898e0f4bb3e8496d9abd3
pkgname = python2-markupsafe
diff --git a/.editorconfig b/.editorconfig
deleted file mode 100644
index a467ee9a97a6..000000000000
--- a/.editorconfig
+++ /dev/null
@@ -1,8 +0,0 @@
-root = true
-
-[*]
-charset = utf-8
-end_of_line = lf
-insert_final_newline = true
-indent_style = tab
-tab_width = 4
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..33f4e24f5b6e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,8 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!*.diff
+!*.hook
+!*.install
+!*.patch
diff --git a/PKGBUILD b/PKGBUILD
index 6821d739709f..ae1dfd92ccf6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,30 @@
-# Maintainer: Daniel Peukert <daniel@peukert.cc>
+# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
+# Contributor: Daniel Peukert <daniel@peukert.cc>
# Contributor: Felix Yan <felixonmars@archlinux.org>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Alex Anthony <alex.anthony28991@gmail.com>
-_projectname='markupsafe'
-pkgname="python2-$_projectname"
-pkgver='1.1.1'
-pkgrel='8'
-pkgdesc='Implements a XML/HTML/XHTML Markup safe string for Python - python2 version'
+
+pkgname='python2-markupsafe'
+_name='MarkupSafe'
+pkgver=1.1.1
+pkgrel=9
+pkgdesc='Safely add untrusted strings to HTML/XML markup'
arch=('x86_64')
-url='https://pypi.python.org/pypi/MarkupSafe'
+url="https://pypi.python.org/pypi/MarkupSafe/${pkgver}"
license=('BSD')
depends=('python2')
makedepends=('python2-setuptools')
-checkdepends=('python2-pytest-runner')
-source=("$pkgname-$pkgver-$pkgrel.tar.gz::https://github.com/pallets/$_projectname/archive/$pkgver.tar.gz")
-sha256sums=('222a10e3237d92a9cd45ed5ea882626bc72bc5e0264d3ed0f2c9129fa69fc167')
-
-_sourcedirectory="$_projectname-$pkgver"
+_tarname="${_name}-${pkgver}"
+source=("${_tarname}.tar.gz::https://pypi.python.org/packages/source/${_name::1}/${_name}/${_tarname}.tar.gz")
+b2sums=('184ab0bc42f8d254ef4239f700f019c0a380bdf2117dfe1abe2eb4dfa0f037158d181a120d8654a6971e9c8badb078f997e3a8bf231898e0f4bb3e8496d9abd3')
build() {
- cd "$srcdir/$_sourcedirectory/"
+ cd "${_tarname}"
python2 setup.py build
}
-check() {
- cd "$srcdir/$_sourcedirectory/"
- python2 setup.py pytest
-}
-
package() {
- cd "$srcdir/$_sourcedirectory/"
- python2 setup.py install --root="$pkgdir/" --optimize=1
- install -Dm644 'LICENSE.rst' "$pkgdir/usr/share/licenses/$pkgname/LICENSE.rst"
+ cd "${_tarname}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm 644 'LICENSE.rst' -t "${pkgdir}/usr/share/licenses/${pkgname}"
}