summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikita Volodin [Никита Володин]2015-06-23 00:00:34 -0300
committerNikita Volodin [Никита Володин]2015-06-23 00:00:34 -0300
commit7c8de317bfe74749bc2a265c14a734e47dd11ca2 (patch)
tree21d42872083aaf1e725287241990d929746c3f62
downloadaur-7c8de317bfe74749bc2a265c14a734e47dd11ca2.tar.gz
feat(python2-meteor-ejson): initial import
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD22
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..482f79f780af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-meteor-ejson
+ pkgdesc = Encoder and Decoder for Extended JSON (EJSON) as used in Meteor and DDP.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/lyschoening/meteor-ejson-python
+ arch = any
+ license = MIT
+ depends = python2
+ depends = python2-six
+ source = https://pypi.python.org/packages/source/m/meteor-ejson/meteor-ejson-1.0.0.tar.gz
+ md5sums = 90952e08f858e936ea6703e503c6f01c
+
+pkgname = python2-meteor-ejson
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8e7aa272f6d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*~
+
+pkg/
+src/
+
+*.tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2093eef36c8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+#Automatically generated by pip2arch on 2015-06-22
+
+pkgname=python2-meteor-ejson
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Encoder and Decoder for Extended JSON (EJSON) as used in Meteor and DDP."
+url="https://github.com/lyschoening/meteor-ejson-python"
+depends=('python2' 'python2-six')
+license=('MIT')
+arch=('any')
+source=("https://pypi.python.org/packages/source/m/meteor-ejson/meteor-ejson-$pkgver.tar.gz")
+md5sums=('90952e08f858e936ea6703e503c6f01c')
+
+build() {
+ cd "$srcdir/meteor-ejson-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/meteor-ejson-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}