summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2014-02-01 21:21:37 +0100
committerBenjamin Chrétien2014-02-01 21:24:23 +0100
commit6f39b6b7a45bd64c094f72a64bd092bf554aeb2c (patch)
tree72360aca31dc412c90ad5bcdb73a6fd64fe4fe9f
downloadaur-6f39b6b7a45bd64c094f72a64bd092bf554aeb2c.tar.gz
Add openni2 with pkg-config file + metapod + cpplog + updates
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed103ee6396c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-mpldatacursor
+ pkgdesc = Interactive data cursors (clickable annotation boxes) for matplotlib.
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/joferkington/mpldatacursor
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = python2-matplotlib>=0.9
+ depends = python2-numpy>=1.1
+ source = mpldatacursor::git+https://github.com/joferkington/mpldatacursor.git#tag=v0.5.0
+ md5sums = SKIP
+
+pkgname = python2-mpldatacursor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e21d753703d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id$
+# Maintainer: Benjamin Chretien <chretien at lirmm dot fr>
+
+pkgname=python2-mpldatacursor
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="Interactive data cursors (clickable annotation boxes) for matplotlib."
+arch=('i686' 'x86_64')
+url='https://github.com/joferkington/mpldatacursor'
+license=('MIT')
+depends=('python2-matplotlib>=0.9' 'python2-numpy>=1.1')
+
+_gitroot=https://github.com/joferkington
+_gitrepo=mpldatacursor
+
+_tag=v${pkgver}
+_dir=${_gitrepo}
+source=("${_dir}"::"git+${_gitroot}/${_gitrepo}.git"#tag=${_tag})
+md5sums=('SKIP')
+
+build() {
+ cd ${srcdir}/${_dir}
+ python2 setup.py build
+}
+
+package() {
+ cd ${srcdir}/${_dir}
+ python2 setup.py install -O1 --skip-build --root "${pkgdir}" --prefix=/usr
+}
+
+