summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2016-01-20 15:26:42 +0900
committerBenjamin Chrétien2016-01-20 15:26:42 +0900
commitf15b68117f3e379f9f5de3c58fec006559da21c7 (patch)
tree029266174e9c398783537f8693245a504ed299cd
parent6f39b6b7a45bd64c094f72a64bd092bf554aeb2c (diff)
downloadaur-f15b68117f3e379f9f5de3c58fec006559da21c7.tar.gz
Update to version 0.6.1 (pkgrel 1)
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD34
2 files changed, 25 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed103ee6396c..ea89795526d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
+# Generated by mksrcinfo v8
+# Wed Jan 20 06:26:36 UTC 2016
pkgbase = python2-mpldatacursor
- pkgdesc = Interactive data cursors (clickable annotation boxes) for matplotlib.
- pkgver = 0.5.0
+ pkgdesc = Interactive data cursors for Matplotlib
+ pkgver = 0.6.1
pkgrel = 1
- url = https://github.com/joferkington/mpldatacursor
- arch = i686
- arch = x86_64
+ url = https://github.com/joferkington/mpldatacursor/
+ arch = any
license = MIT
- depends = python2-matplotlib>=0.9
- depends = python2-numpy>=1.1
- source = mpldatacursor::git+https://github.com/joferkington/mpldatacursor.git#tag=v0.5.0
- md5sums = SKIP
+ makedepends = python2-distribute
+ makedepends = python2-matplotlib
+ makedepends = python2-numpy
+ depends = python2
+ source = https://pypi.python.org/packages/source/m/mpldatacursor/mpldatacursor-0.6.1.tar.gz
+ sha256sums = 156dc422d5ddf666043e99a695cae8e9de1fded5ca2f519e64ff4186640fc3cc
pkgname = python2-mpldatacursor
diff --git a/PKGBUILD b/PKGBUILD
index 0e21d753703d..2e9bbb4dc687 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,23 @@
-# $Id$
-# Maintainer: Benjamin Chretien <chretien at lirmm dot fr>
+#Automatically generated by pip2arch on 2016-01-20
pkgname=python2-mpldatacursor
-pkgver=0.5.0
+pkgver=0.6.1
pkgrel=1
-pkgdesc="Interactive data cursors (clickable annotation boxes) for matplotlib."
-arch=('i686' 'x86_64')
-url='https://github.com/joferkington/mpldatacursor'
+pkgdesc="Interactive data cursors for Matplotlib"
+url="https://github.com/joferkington/mpldatacursor/"
+depends=('python2' )
+makedepends=('python2-distribute' 'python2-matplotlib' 'python2-numpy')
license=('MIT')
-depends=('python2-matplotlib>=0.9' 'python2-numpy>=1.1')
-
-_gitroot=https://github.com/joferkington
-_gitrepo=mpldatacursor
-
-_tag=v${pkgver}
-_dir=${_gitrepo}
-source=("${_dir}"::"git+${_gitroot}/${_gitrepo}.git"#tag=${_tag})
-md5sums=('SKIP')
+arch=('any')
+source=("https://pypi.python.org/packages/source/m/mpldatacursor/mpldatacursor-${pkgver}.tar.gz")
+sha256sums=('156dc422d5ddf666043e99a695cae8e9de1fded5ca2f519e64ff4186640fc3cc')
build() {
- cd ${srcdir}/${_dir}
- python2 setup.py build
+ cd "${srcdir}/mpldatacursor-${pkgver}"
+ python2 setup.py build
}
package() {
- cd ${srcdir}/${_dir}
- python2 setup.py install -O1 --skip-build --root "${pkgdir}" --prefix=/usr
+ cd "${srcdir}/mpldatacursor-${pkgver}"
+ python2 setup.py install --root="$pkgdir" --optimize=1
}
-
-