summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJelle van der Waa2021-11-29 20:06:59 +0100
committerJelle van der Waa2021-11-29 20:06:59 +0100
commitee36ee375892ab99c26930efaf7e66a4fecd483d (patch)
tree7eb99fe296da3a9e79f212d3511735bf45ceca71
downloadaur-ee36ee375892ab99c26930efaf7e66a4fecd483d.tar.gz
import from community
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..94e89c8a809f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-msgpack
+ pkgdesc = MessagePack serializer implementation for Python
+ pkgver = 0.6.2
+ pkgrel = 4
+ url = https://github.com/msgpack/msgpack-python
+ arch = x86_64
+ license = Apache
+ checkdepends = python2-pytest
+ checkdepends = python2-six
+ makedepends = cython2
+ makedepends = python2-setuptools
+ depends = python2
+ source = msgpack-python-0.6.2.tar.gz::https://github.com/msgpack/msgpack-python/archive/v0.6.2.tar.gz
+ sha512sums = be4a65592acf3c2a4fcd5d6c603f5a3346f0bccb4864d82a729d47308a11d990f7137e66a9d6df7309a892d189f62e8a9efbda022b7ef2a09338012aa1634b6d
+
+pkgname = python2-msgpack
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c99301b6bd10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Johannes Löthberg <johannes@kyriasis.com>
+# Contributor: SĂ©bastien "Seblu" Luttringer
+
+pkgname=python2-msgpack
+pkgver=0.6.2
+pkgrel=4
+pkgdesc='MessagePack serializer implementation for Python'
+
+
+url='https://github.com/msgpack/msgpack-python'
+arch=('x86_64')
+license=('Apache')
+
+depends=('python2')
+makedepends=('cython2' 'python2-setuptools')
+checkdepends=('python2-pytest' 'python2-six')
+
+source=(msgpack-python-$pkgver.tar.gz::https://github.com/msgpack/msgpack-python/archive/v$pkgver.tar.gz)
+
+sha512sums=('be4a65592acf3c2a4fcd5d6c603f5a3346f0bccb4864d82a729d47308a11d990f7137e66a9d6df7309a892d189f62e8a9efbda022b7ef2a09338012aa1634b6d')
+
+build() {
+ cd msgpack-python-$pkgver
+ python2 setup.py build --build-lib=build/python
+}
+
+check() {
+ cd msgpack-python-$pkgver
+ PYTHONPATH=$PWD/build/python py.test2 test
+}
+
+package() {
+ cd msgpack-python-$pkgver
+ python2 setup.py build --build-lib=build/python \
+ install --root="$pkgdir" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: