summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHector Mtz-Seara2016-03-10 13:01:12 +0100
committerHector Mtz-Seara2016-03-10 13:03:03 +0100
commit5fc41d037ce5282f7715640e4db55fdc5a549f1e (patch)
tree2a5869c58d5f89cf4832656cce65156cd0d6f6d4
downloadaur-5fc41d037ce5282f7715640e4db55fdc5a549f1e.tar.gz
Initial commit as standalone package
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD44
-rw-r--r--patch.i0.c12
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fdadbfcb6a49
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python2-msmbuilder
+ pkgdesc = A python package which implements a series of statistical models for high-dimensional time-series
+ pkgver = 3.3.1
+ pkgrel = 4
+ url = http://msmbuilder.org/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = python2-setuptools
+ depends = python2-mdtraj
+ depends = python2-cvxopt
+ depends = python2-scikit-learn
+ optdepends = python2-numpydoc: XXX
+ options = !libtool
+ source = https://github.com/msmbuilder/msmbuilder/archive/3.3.1.tar.gz
+ source = patch.i0.c
+ sha1sums = fcb5ad6fabb5aead4c78d3fed782665d090c0caa
+ sha1sums = f0129777e7f9fb28074b86d47d6bb8b94f763063
+
+pkgname = python2-msmbuilder
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe8d974e597f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Contributor: Hector <hsearaDOTatDOTgmailDOTcom>
+
+
+pkgname=('python2-msmbuilder')
+pkgver=3.3.1
+pkgrel=4
+pkgdesc='A python package which implements a series of statistical models for high-dimensional time-series'
+url='http://msmbuilder.org/'
+license=("LGPL")
+arch=('i686' 'x86_64')
+depends=('python2-mdtraj' 'python2-cvxopt' 'python2-scikit-learn')
+optdepends=('python2-numpydoc: XXX')
+makedepends=('python2-setuptools')
+options=('!libtool')
+source=("https://github.com/msmbuilder/msmbuilder/archive/${pkgver}.tar.gz"
+ "patch.i0.c")
+sha1sums=('fcb5ad6fabb5aead4c78d3fed782665d090c0caa'
+ 'f0129777e7f9fb28074b86d47d6bb8b94f763063')
+
+prepare() {
+ cd "$srcdir"
+ cp patch.i0.c msmbuilder-3.3.1/msmbuilder/hmm/cephes/
+ cd msmbuilder-3.3.1/msmbuilder/hmm/cephes/
+ patch i0.c < patch.i0.c
+}
+
+build() {
+ msg2 "Building msmbuilder - Python 2"
+ cd "${srcdir}/msmbuilder-${pkgver}"
+ python2 setup.py build
+
+}
+package() {
+ msg2 "Installing msmbuilder python2"
+ cd "${srcdir}/msmbuilder-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+
+ # Remove left over directories from distribute utils.
+ find ${pkgdir} -type d -name "__pycache__" -exec rm -r {} \; -prune
+
+ #Rename msmb executable to avoid problems with "python-msmbuilder"
+ cd ${pkgdir}/usr/bin
+ mv msmb msmb_py2
+}
diff --git a/patch.i0.c b/patch.i0.c
new file mode 100644
index 000000000000..b4f526012da9
--- /dev/null
+++ b/patch.i0.c
@@ -0,0 +1,12 @@
+--- i0.c_old 2015-11-19 23:33:45.000000000 +0100
++++ i0.c 2016-03-09 14:17:04.214784592 +0100
+@@ -75,8 +75,8 @@
+ */
+
+ #include "cephes.h"
+-#include "mconf.h"
+ #include "math.h"
++#include "mconf.h"
+
+ /* Chebyshev coefficients for exp(-x) I0(x)
+ * in the interval [0,8].