summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBastien Traverse2021-02-22 21:16:35 +0100
committerBastien Traverse2021-02-22 22:38:37 +0100
commit6b6e385cf71aedc0ff54f00d13d2fc804b45cdb4 (patch)
tree857a9d145c1d2cf36a738f0f56231d169ef35b33
parent9de1b6ac35bad925308a93880d6a27906b9e6f3b (diff)
downloadaur-6b6e385cf71aedc0ff54f00d13d2fc804b45cdb4.tar.gz
Update to latest Python 2 version (1.43.1)
- use upstream-provided SHA256 checksum
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02e65026159b..5ea0dfaf7160 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = python2-mutagen
pkgdesc = An audio metadata tag reader and writer (python2 library)
- pkgver = 1.43.0
- pkgrel = 3
+ pkgver = 1.43.1
+ pkgrel = 1
url = https://github.com/quodlibet/mutagen
arch = any
license = GPL2
depends = python2-setuptools
- source = https://github.com/quodlibet/mutagen/releases/download/release-1.43.0/mutagen-1.43.0.tar.gz
- source = https://github.com/quodlibet/mutagen/releases/download/release-1.43.0/mutagen-1.43.0.tar.gz.sig
+ source = https://github.com/quodlibet/mutagen/releases/download/release-1.43.1/mutagen-1.43.1.tar.gz
+ source = https://github.com/quodlibet/mutagen/releases/download/release-1.43.1/mutagen-1.43.1.tar.gz.sig
validpgpkeys = 0EBF782C5D53F7E5FB02A66746BD761F7A49B0EC
- sha512sums = 66df63705a43befa9cf6688bc8b3acc4fd1559eb28920c105b47a97c35422b5e19527051445daa7aed66facc2e4c14d71058f8560bbd564fecbe56a076491e3f
- sha512sums = SKIP
+ sha256sums = d873baeb7815311d3420aab0a1d83f050f628228cbc2d6045a14a16460411bc9
+ sha256sums = SKIP
pkgname = python2-mutagen
diff --git a/PKGBUILD b/PKGBUILD
index ca053f53e4cb..598cc92bab0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
-# Maintainer: David Runge <dvzrv@archlinux.org>
+# Maintainer:
+# Contributor: Bastien Traverse <neitsab at esrevart dot net>
+# Contributor: David Runge <dvzrv@archlinux.org>
_name=mutagen
pkgname=python2-mutagen
-pkgver=1.43.0
-pkgrel=3
+pkgver=1.43.1
+pkgrel=1
arch=('any')
pkgdesc="An audio metadata tag reader and writer (python2 library)"
url="https://github.com/quodlibet/mutagen"
license=('GPL2')
depends=('python2-setuptools')
source=("https://github.com/quodlibet/${_name}/releases/download/release-$pkgver/${_name}-$pkgver.tar.gz"{,.sig})
-sha512sums=('66df63705a43befa9cf6688bc8b3acc4fd1559eb28920c105b47a97c35422b5e19527051445daa7aed66facc2e4c14d71058f8560bbd564fecbe56a076491e3f'
+sha256sums=('d873baeb7815311d3420aab0a1d83f050f628228cbc2d6045a14a16460411bc9'
'SKIP')
validpgpkeys=('0EBF782C5D53F7E5FB02A66746BD761F7A49B0EC') # Christoph Reiter <reiter.christoph@gmail.com>
@@ -24,7 +26,7 @@ prepare() {
}
build() {
- cd "${pkgbase}-${pkgver}"
+ cd "${pkgname}-${pkgver}"
python2 setup.py build
}