summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Vogt2015-08-03 08:27:54 +0200
committerDavid Vogt2015-08-03 08:28:46 +0200
commitb8798d8b8837e2fce1f55061039949797049c55f (patch)
treeb0b15e58dfa39f11dbc6068611ca27ec73112963
parent69ff517ffb1bdafcadd95dcc5576a3aae81e5350 (diff)
downloadaur-b8798d8b8837e2fce1f55061039949797049c55f.tar.gz
Add warning when building within a virtualenv
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3c9f96e4329a..f2e6bf3ff0a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python2-neovim-git
_pkgname=python2-neovim-git
-pkgver=0.r242.8051657
+pkgver=0.r262.605897b
pkgrel=1
pkgdesc="Python client to neovim, git version. Use this to keep up with neovim-git"
arch=('any')
@@ -27,6 +27,12 @@ source=("$pkgname::git://github.com/neovim/python-client.git"
"LICENSE::https://raw.githubusercontent.com/neovim/python-client/master/LICENSE")
sha256sums=('SKIP' '297a62ff61eb84f532ff5a8181860d925b710d4458f204e56c90b1da997c8711')
+if [ -n "$VIRTUAL_ENV" ]; then
+ echo "Warning: You're building within a virtualenv. Use"
+ echo "a shell without virtualenv to build this package!"
+ exit 1
+fi
+
pkgver() {
cd "${_pkgname}"
printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"