summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRich Li2015-06-08 13:22:37 -0600
committerRich Li2015-06-08 13:22:37 -0600
commit41d0df99d9264c76339e2f86b837c408b1d58544 (patch)
tree259a6ca6bcc038aa5ac7fea623d3f7ac2c60a53a
downloadaur-41d0df99d9264c76339e2f86b837c408b1d58544.tar.gz
Import v1.1.8 from old AUR
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD55
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2e14bbee152
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python2-netcdf4
+ pkgdesc = Python/numpy interface to the netCDF version 4 library.
+ pkgver = 1.1.8
+ pkgrel = 1
+ url = https://unidata.github.io/netcdf4-python/
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = python2-setuptools
+ makedepends = cython2
+ depends = python2-numpy
+ depends = netcdf
+ depends = hdf5
+ depends = curl
+ depends = zlib
+ optdepends = python-netcdf4: python 3 version
+ source = https://github.com/Unidata/netcdf4-python/archive/v1.1.8rel.tar.gz
+ md5sums = 1c63b736e8479b263832690b399a7660
+
+pkgname = python2-netcdf4
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8c7166d92ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: richli <rich at dranek dot com>
+# Contributor: Spyros Stathopoulos <foucault.online@gmail.com>
+# Contributor: rememberthemer <rememberthemer@_GMAIL_DOT_COM_>
+
+pkgname=python2-netcdf4
+pkgver=1.1.8
+pkgrel=1
+pkgdesc="Python/numpy interface to the netCDF version 4 library."
+arch=('x86_64' 'i686')
+url="https://unidata.github.io/netcdf4-python/"
+license=('MIT')
+
+depends=('python2-numpy' 'netcdf' 'hdf5' 'curl' 'zlib')
+makedepends=('python2-setuptools' 'cython2')
+optdepends=('python-netcdf4: python 3 version')
+source=(https://github.com/Unidata/netcdf4-python/archive/v${pkgver}rel.tar.gz)
+md5sums=('1c63b736e8479b263832690b399a7660')
+
+build() {
+ cd "$srcdir"/netcdf4-python-${pkgver}rel
+ # USE_NCCONFIG=1 python2 setup.py clean --all
+ USE_NCCONFIG=1 python2 setup.py build
+}
+
+check() {
+ cd "$srcdir"/netcdf4-python-${pkgver}rel
+ cd "test"
+ PYTHONPATH="../build/lib.linux-${CARCH}-2.7" python2 -B ./run_all.py
+}
+
+package() {
+ cd "$srcdir"/netcdf4-python-${pkgver}rel
+
+ # Note that this installs the python2 package as well as some scripts in /usr/bin
+ USE_NCCONFIG=1 python2 setup.py install --prefix=/usr \
+ --root="$pkgdir" --skip-build --optimize 2
+
+ # We don't need to install the test suite if we already use it in check()
+ # install -m755 -d "$pkgdir"/usr/share/doc/$pkgname/test
+ # install -m644 -t "$pkgdir"/usr/share/doc/$pkgname/test test/*
+
+ # Install documentation
+ install -m755 -d "$pkgdir/usr/share/doc/$pkgname/docs"
+ install -m644 -t "$pkgdir/usr/share/doc/$pkgname/docs" docs/*
+
+ # The examples include over 100 MB of binary data, so we don't install it by default
+ # install -m755 -d "$pkgdir/usr/share/doc/$pkgname/examples"
+ # install -m755 -d "$pkgdir/usr/share/doc/$pkgname/examples/data"
+ # find examples -maxdepth 1 -type f -execdir install -m644 -t "$pkgdir/usr/share/doc/$pkgname/examples" {} \+
+ # find examples/data -maxdepth 1 -type f -execdir install -m644 -t "$pkgdir/usr/share/doc/$pkgname/examples/data" {} \+
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim: set et sw=4 ts=4 sts=4: